Bug 1277536 - [abrt] gtk3-demo: find_class_funcs(): gtk3-demo killed by SIGSEGV
[abrt] gtk3-demo: find_class_funcs(): gtk3-demo killed by SIGSEGV
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:7356e249374cd727e619d6828d5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 09:14 EST by Christian Stadelmann
Modified: 2015-12-17 20:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 20:27:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (90.35 KB, text/plain)
2015-11-03 09:14 EST, Christian Stadelmann
no flags Details
File: core_backtrace (24.59 KB, text/plain)
2015-11-03 09:14 EST, Christian Stadelmann
no flags Details
File: dso_list (26.27 KB, text/plain)
2015-11-03 09:14 EST, Christian Stadelmann
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-03 09:14 EST, Christian Stadelmann
no flags Details
File: maps (132.46 KB, text/plain)
2015-11-03 09:14 EST, Christian Stadelmann
no flags Details
File: open_fds (5.43 KB, text/plain)
2015-11-03 09:14 EST, Christian Stadelmann
no flags Details
File: proc_pid_status (1013 bytes, text/plain)
2015-11-03 09:14 EST, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-11-03 09:14:01 EST
Version-Release number of selected component:
evolution-3.18.1-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        evolution
crash_function: find_class_funcs
executable:     /usr/bin/evolution
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           CCpp

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 find_class_funcs at inspector/object-tree.c:506
 #1 gtk_inspector_object_tree_find_object at inspector/object-tree.c:524
 #4 gtk_object_tree_remove_dead_object at inspector/object-tree.c:616
 #5 weak_refs_notify at gobject.c:2634
 #7 g_hash_table_remove_all_nodes at ghash.c:548
 #8 g_hash_table_remove_all at ghash.c:1425
 #10 g_hash_table_destroy at ghash.c:1122
 #11 g_hash_table_remove_all_nodes at ghash.c:548
 #12 g_hash_table_remove_all at ghash.c:1425
 #14 g_hash_table_destroy at ghash.c:1122
Comment 1 Christian Stadelmann 2015-11-03 09:14:07 EST
Created attachment 1089006 [details]
File: backtrace
Comment 2 Christian Stadelmann 2015-11-03 09:14:08 EST
Created attachment 1089007 [details]
File: core_backtrace
Comment 3 Christian Stadelmann 2015-11-03 09:14:10 EST
Created attachment 1089008 [details]
File: dso_list
Comment 4 Christian Stadelmann 2015-11-03 09:14:12 EST
Created attachment 1089009 [details]
File: limits
Comment 5 Christian Stadelmann 2015-11-03 09:14:14 EST
Created attachment 1089010 [details]
File: maps
Comment 6 Christian Stadelmann 2015-11-03 09:14:16 EST
Created attachment 1089011 [details]
File: open_fds
Comment 7 Christian Stadelmann 2015-11-03 09:14:17 EST
Created attachment 1089012 [details]
File: proc_pid_status
Comment 8 Milan Crha 2015-11-04 02:24:02 EST
Thanks for a bug report. I'm moving this to gtk3, because I can reproduce the crash also under gtk3-demo, out of the evolution.

Steps:
a) enable the gtk inspector in settings
b) run gtk3-demo->Pickers
c) select for example the Folder picker and choose "Other folder"
d) press Ctrl+I to open the inspector when the file chooser is opened
e) switch to the file chooser (keep the object inspector opened) and Cancel it
f) close the Picker demo with the 'X' button (object inspector is kept opened)

The gtk3-demo crashed at this point.

I do not know whether this qualifies as a real bug report, because there is a clear warning that using the inspector can lead also to crashes, which just happened here, but I left the final word to the gtk3 maintainers.
Comment 9 Matthias Clasen 2015-12-17 20:27:42 EST
Not worth keeping a downstream bug open about; it might be fixed already anyway.

Note You need to log in before you can comment on or make changes to this bug.