Bug 1277617 - Dependency fails for 0:0.5.0-1.
Dependency fails for 0:0.5.0-1.
Status: CLOSED DUPLICATE of bug 1277378
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 11:32 EST by Frank Büttner
Modified: 2015-11-03 11:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 11:51:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2015-11-03 11:32:51 EST
Description of problem:
Unable to install the update

Version-Release number of selected component (if applicable):
dnf-plugin-system-upgrade.noarch 0:0.5.0-1.fc21

How reproducible:
every time

Steps to Reproduce:
1. yum update

Actual results:
--> Running transaction check
---> Package dnf-plugin-system-upgrade.noarch 0:0.5.0-1.fc21 will be obsoleting
--> Processing Dependency: python2-dnf-plugin-system-upgrade for package: dnf-plugin-system-upgrade-0.5.0-1.fc21.noarch
---> Package fedup.noarch 0:0.9.2-1.fc21 will be obsoleted
---> Package fedup-dracut.x86_64 0:0.9.0-1.fc21 will be obsoleted
--> Processing Dependency: fedup-dracut for package: lorax-21.33-1.fc21.x86_64
--> Running transaction check
---> Package fedup-dracut.x86_64 0:0.9.0-1.fc21 will be obsoleted
--> Processing Dependency: fedup-dracut for package: lorax-21.33-1.fc21.x86_64
---> Package python2-dnf-plugin-system-upgrade.noarch 0:0.5.0-1.fc21 will be installed
--> Finished Dependency Resolution
Error: Package: lorax-21.33-1.fc21.x86_64 (installed)
           Requires: fedup-dracut
           Removing: fedup-dracut-0.9.0-1.fc21.x86_64 (installed)
               fedup-dracut = 0.9.0-1.fc21
           Obsoleted By: dnf-plugin-system-upgrade-0.5.0-1.fc21.noarch (updates)
               Not found
 You could try using --skip-broken to work around the problem



Expected results:
Working update
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-11-03 11:51:30 EST
Please remove fedup dracut first with 'dnf remove fedup-dracut'. It's not used anymore.

*** This bug has been marked as a duplicate of bug 1277378 ***

Note You need to log in before you can comment on or make changes to this bug.