Bug 1277664 - New domain dialog suggests keeping non-existent defaults
New domain dialog suggests keeping non-existent defaults
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Tal Nisan
Elad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 14:11 EST by jniederm
Modified: 2016-07-05 03:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:50:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
new domain dialog (33.35 KB, image/png)
2015-11-03 14:11 EST, jniederm
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48062 master MERGED Revert "engine: IntegerValidation refactor" Never
oVirt gerrit 48080 master ABANDONED webadmin: add parseShort to StringUtils 2016-05-09 01:40 EDT
oVirt gerrit 48081 master ABANDONED webadmin: Introduce ShortValidation 2016-05-09 01:40 EDT
oVirt gerrit 48082 master ABANDONED engine: IntegerValidation refactor 2016-05-09 01:40 EDT

  None (edit)
Description jniederm 2015-11-03 14:11:20 EST
Created attachment 1089180 [details]
new domain dialog

Description of problem:
New domain dialog 

Version-Release number of selected component (if applicable):
4.0 master, commit 5ecb518

How reproducible:
100%

Steps to Reproduce:
1. WebAdmin > Storage tab
2. Open New domain dialog
3. Set Domain Function: ISO
       Name
       Export Path
4. click Ok

Actual results:
Dialog does nothing visible (no hints for user). Clicking "Custom Connection Parameters" reveals that fields "Retransmissions (#)" and "Timeout (deciseconds)" are required but not filled. However there is a confusing warning 
"It is recommended to keep the default values in the fields below unchanged."
at the same time.

Expected results:
ISO domain created
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-04 07:53:03 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 2 Allon Mureinik 2016-02-14 05:05:07 EST
This is bug introduced in the master (4.0) branch, which is not present in any 3.6.z release.

As it's already fixed, lowering severity to HIGH so the urgent-bug whine stops nagging me about this.
Comment 3 Natalie Gavrielov 2016-04-10 11:16:02 EDT
The only thing that was changed here is the red marks over Retransmissions and Timeout fields..
Was that the intention?
I would guess that the default values of these fields should be displayed..
Comment 4 Elad 2016-04-14 09:34:26 EDT
ISO domain gets created successfully using the default values (Retransmissions (#) and Timeout (deciseconds))

Used:
ovirt-engine-4.0.0-0.0.master.20160406161747.gita4ecba2.el7.centos.noarch
Comment 5 Tal Nisan 2016-04-17 06:58:26 EDT
Natalie - The problem was that the domain couldn't be created so this bug was fixed and the old behavior restored
Comment 6 Sandro Bonazzola 2016-07-05 03:50:13 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.