Bug 127778 - ghostscript can't find libomni
ghostscript can't find libomni
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-13 14:03 EDT by Matt Hyclak
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 7.07-28
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 03:54:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Hyclak 2004-07-13 14:03:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:
I have a LaserJet 5mp, configured via the cups interface with ppd from
linuxprinting.org. Ghostscript would crash not being able to find
libomni.so.0. Below is the error message with Loglevel set to debug2.

D [13/Jul/2004:11:58:31 -0400] [Job 6] GNU Ghostscript 7.07 (2003-05-17)
D [13/Jul/2004:11:58:31 -0400] [Job 6] Copyright (C) 2003 artofcode
LLC, Benicia, CA.  All rights reserved.
D [13/Jul/2004:11:58:31 -0400] [Job 6] This software comes with NO
WARRANTY: see the file PUBLIC for details.
D [13/Jul/2004:11:58:31 -0400] [Job 6] <<<<<<<<<<<<<<<<<<<<<< ERROR
>>>>>>>>>>>>>>>>>>>>>>>
D [13/Jul/2004:11:58:31 -0400] [Job 6]
D [13/Jul/2004:11:58:31 -0400] [Job 6] Error: Could not load libomni.so
D [13/Jul/2004:11:58:31 -0400] [Job 6] Error: Loading
"/usr/lib/Omni/libomni.so" returns "/usr/lib/Omni/libomni.so: cannot
open shared object file: No such file or directory"
D [13/Jul/2004:11:58:31 -0400] [Job 6] Error: Loading
"/opt/Omni/bin/libomni.so" returns "/opt/Omni/bin/libomni.so: cannot
open shared object file: No such file or directory"
D [13/Jul/2004:11:58:31 -0400] [Job 6] Error: Loading
"/opt/Omni/lib/libomni.so" returns "/opt/Omni/lib/libomni.so: cannot
open shared object file: No such file or directory"
D [13/Jul/2004:11:58:31 -0400] [Job 6] Error: Loading "./libomni.so"
returns "./libomni.so: cannot open shared object file: No such file or
directory"
D [13/Jul/2004:11:58:31 -0400] [Job 6] Error: Loading "libomni.so"
returns "libomni.so: cannot open shared object file: No such file or
directory"
D [13/Jul/2004:11:58:31 -0400] [Job 6]
D [13/Jul/2004:11:58:31 -0400] [Job 6] <<<<<<<<<<<<<<<<<<<<<< ERROR
>>>>>>>>>>>>>>>>>>>>>>>
D [13/Jul/2004:11:58:31 -0400] [Job 6]
D [13/Jul/2004:11:58:31 -0400] [Job 6] Error: Could not load libomni.so
D [13/Jul/2004:11:58:31 -0400] [Job 6] renderer return value: 1
D [13/Jul/2004:11:58:31 -0400] [Job 6] renderer received signal: 1
D [13/Jul/2004:11:58:31 -0400] [Job 6] Process dying with "Possible
error on renderer command line or PostScript error. Check options.",
exit stat: 3
D [13/Jul/2004:11:58:31 -0400] [Job 6] Possible error on renderer
command line or PostScript error. Check options.
D [13/Jul/2004:11:58:31 -0400] [Job 6] tail process done writing data
to STDOUT
D [13/Jul/2004:11:58:31 -0400] [Job 6] KID4 finished
D [13/Jul/2004:11:58:31 -0400] [Job 6] Saw EOF!
D [13/Jul/2004:11:58:31 -0400] [Job 6]
D [13/Jul/2004:11:58:31 -0400] [Job 6] Closing renderer
D [13/Jul/2004:11:58:31 -0400] [Job 6] KID3 exited with status 3
D [13/Jul/2004:11:58:31 -0400] [Job 6] Renderer exit stat: 3
D [13/Jul/2004:11:58:31 -0400] [Job 6] Renderer process finished
D [13/Jul/2004:11:58:31 -0400] [Job 6] Killing process 6193 (KID3)
D [13/Jul/2004:11:58:31 -0400] [Job 6] Process dying with "Error
closing renderer", exit stat: 3
D [13/Jul/2004:11:58:31 -0400] [Job 6] Error closing renderer


Version-Release number of selected component (if applicable):
ghostscript-7.07-25

How reproducible:
Always

Steps to Reproduce:
1. Print with the omni driver for ghostscript
    

Actual Results:  CUPS exits because ghostscript fails

Expected Results:  CUPS prints my document :-)

Additional info:

Symlinking /usr/lib/Omni to /usr/lib64/Omni solves the problem, but is
ugly.
Comment 1 Tim Waugh 2004-07-14 03:54:34 EDT
Yes, I noticed this last month, and it was fixed in 7.07-28 in Fedora
development.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.