This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1277824 - "VFS: Cannot open root device" on Beagle Bone Black
"VFS: Cannot open root device" on Beagle Bone Black
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
armhfp Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 02:15 EST by Ken
Modified: 2015-11-04 10:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 10:47:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from serial port after upgrade to Fedora 23 on Beagle Bone Black (14.18 KB, text/plain)
2015-11-04 02:15 EST, Ken
no flags Details

  None (edit)
Description Ken 2015-11-04 02:15:10 EST
Created attachment 1089428 [details]
Output from serial port after upgrade to Fedora 23 on Beagle Bone Black

Description of problem:

I just upgraded to Fedora 23 on a "Beagle bone black"

The kernel panics because :

VFS: Cannot open root device "UUID=e098e36f-f409-44cb-9d8e-9d5c0e2ed9c9" or unknown-block(0,0): error -6

Version-Release number of selected component (if applicable):

kernel-core-4.2.3-300.fc23.armv7hl

How reproducible:

Every time

Steps to Reproduce:
1. Try to boot the machine
2. Kernel panic

Actual results:

[    1.538065] VFS: Cannot open root device "UUID=e098e36f-f409-44cb-9d8e-9d5c0e2ed9c9" or unknown-block(0,0): error
 -6
[    1.549173] Please append a correct "root=" boot option; here are the available partitions:
[    1.557965] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


Expected results:

Booted kernel

Additional info:

Another odd thing : I booted an older kernel and did :

dnf erase kernel-core-4.2.3-300.fc23.armv7hl
dnf upgrade

which reinstalled the kernel, but then when I tried to boot, u-boot said :

** Unable to read file /dtb-4.2.3-300.fc23.armv7hl/am335x-boneblack.dtb **

... because the DTB directory got installed the wrong place :

/boot/dtb-4.2.3-300.fc23.armv7hl/dtb/am335x-boneblack.dtb

Notice the extra "/dtb/" in the path.  When I fixed this DTB problem, I still got the kernel panic.
Comment 1 Ken 2015-11-04 02:47:57 EST
I noticed 2 strange things on the console :

omap_i2c 44e0b000.i2c: could not find pctldev for node /ocp/l4_wkup@44c00000/scm@210000/pinmux@800/pinmux_i2c0_pins, deferring probe

omap_i2c 4819c000.i2c: could not find pctldev for node /ocp/l4_wkup@44c00000/scm@210000/pinmux@800/pinmux_i2c2_pins, deferring probe



... and :

Initramfs unpacking failed: junk in compressed archive



Oh... now I noticed that there were a bunch of error messages during the system-upgrade process, such as :

mmcqd/0: page allocation failure: order:3, mode:0xc020

omap_hsmmc 48060000.mmc: MMC start dma failure

mmcblk0: unknown error -1 sending read/write command, card status 0x900

blk_update_request: I/O error, dev mmcblk0, sector 2693616

Buffer I/O error on device mmcblk0p3, logical block 165694

... so maybe I didn't get a clean system-upgrade.
Comment 2 Josh Boyer 2015-11-04 10:23:00 EST
As you say, your upgrade seems to have failed.  The panic is because the kernel cannot find the rootfs.  That is likely because the initramfs contains the necessary functionality to find the rootfs, but since it is not valid it doesn't work.  This isn't really a kernel problem.
Comment 3 Ken 2015-11-04 10:47:58 EST
Ohoh .... I plugged this SD card into another system, and gots lots of errors :

[  286.793487] mmc0: Got data interrupt 0x00200000 even though no data operation was in progress.
[  286.797436] mmcblk0: error -84 transferring data, sector 0, nr 8, cmd response 0x900, card status 0xb00


... so I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.