Bug 1277836 - [RFE] perl image doesn't seem to log access to stdout
[RFE] perl image doesn't seem to log access to stdout
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-perl520-docker (Show other bugs)
rh-perl520
Unspecified Unspecified
unspecified Severity low
: alpha
: 2.1
Assigned To: Petr Pisar
XiuJuan Wang
: FutureFeature, Reopened
Depends On:
Blocks: 1231862
  Show dependency treegraph
 
Reported: 2015-11-04 03:23 EST by Honza Horak
Modified: 2015-11-16 11:07 EST (History)
16 users (show)

See Also:
Fixed In Version: rh-perl520-docker-5.20-8
Doc Type: Enhancement
Doc Text:
Feature: Log HTTP accesses to standard output. Reason: User expects the log entries are visible in "oc log" command output. Result: The httpd's access log was redirected to standard output.
Story Points: ---
Clone Of: 1231862
Environment:
Last Closed: 2015-11-16 11:07:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Petr Pisar 2015-11-04 04:14:47 EST
What version did you tested? There is no dist-git commit f3ed77ae8490. Please report the full build name. E.g. rh-perl520-docker-5.20-8.
Comment 2 Petr Pisar 2015-11-04 06:25:35 EST
This has already been fixed in rh-perl520-docker-5.20-8.
Comment 9 XiuJuan Wang 2015-11-09 06:48:03 EST
Works with perl-520-rhel7(imageid:076ec56d14b1)

oc logs dancer-example-1-h47bi
[Mon Nov 09 06:42:04.666644 2015] [so:warn] [pid 1] AH01574: module perl_module is already loaded, skipping
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 10.1.3.56. Set the 'ServerName' directive globally to suppress this message
10.1.3.1 - - [09/Nov/2015:06:46:04 -0500] "GET / HTTP/1.1" 200 42325 "-" "curl/7.29.0"
10.1.3.1 - - [09/Nov/2015:06:46:10 -0500] "GET / HTTP/1.1" 200 42325 "-" "curl/7.29.0"
10.1.3.1 - - [09/Nov/2015:06:46:12 -0500] "GET / HTTP/1.1" 200 42325 "-" "curl/7.29.0"

Move bug to verified
Comment 11 errata-xmlrpc 2015-11-16 11:07:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2058.html

Note You need to log in before you can comment on or make changes to this bug.