Bug 1277839 - rhel-5-server-satellite-tools-6.1-rpms lacks python-ctypes RPM
rhel-5-server-satellite-tools-6.1-rpms lacks python-ctypes RPM
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.1.3
All Linux
low Severity low (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 03:33 EST by Pavel Moravec
Modified: 2017-04-03 08:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-03 08:33:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Moravec 2015-11-04 03:33:04 EST
Description of problem:
Installing katello-agent on fresh RHEL5.7, it tries to install python-gofer-2.6.6-2.el5.noarch that depends on python-ctypes RPM. This RPM is not present on default RHEL5.7 installation neither in rhel-5-server-satellite-tools-6.1-rpms repository (while it is present in rhel-5-server-rpms, I guess).

Please add python-ctypes to rhel-5-server-satellite-tools-6.1-rpms repo.


Version-Release number of selected component (if applicable):
RHEL5.7
Sat6.1.3


How reproducible:
100%


Steps to Reproduce:
1. Freshly installed RHEL5.7
2. register it to Satellite6
3. yum install katello-agent
4. Check where python-ctypes is downloaded from


Actual results:
python-ctypes is downloaded from rhel-5-server-rpms repo


Expected results:
python-ctypes to be downloaded from rhel-5-server-satellite-tools-6.1-rpms repo


Additional info:
(discovered by not having rhel5-rpms repo synced, just rhel-5-server-satellite-tools-6.1-rpms, I cant install katello-agent due to that dependency)
Comment 2 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 3 Bryan Kearney 2016-07-26 11:38:55 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 5 Chris Duryee 2016-09-26 14:09:58 EDT
Per https://access.redhat.com/solutions/1156723, RHEL 5.7 and newer is supported.

Either python-ctypes needs to be carried in the EL5 tools repo, or the docs need to be updated to say RHEL 5.8 and newer.
Comment 7 Tomas Mlcoch 2017-04-03 08:09:27 EDT
Hi Pavel,

Satellite Tools are supported only on supported versions of RHEL.
For RHEL-5 only RHEL-5.9-AUS and RHEL-5-ELS (based on 5.11) are supported.

RHEL-5.7 isn't supported since 2012-02-09:
https://pp.engineering.redhat.com/pp/product/rhel/release/rhel-5-7/schedule/tasks
and Satellite Tools were never provided for it.
Comment 8 Pavel Moravec 2017-04-03 08:33:27 EDT
(In reply to Tomas Mlcoch from comment #7)
> Hi Pavel,
> 
> Satellite Tools are supported only on supported versions of RHEL.
> For RHEL-5 only RHEL-5.9-AUS and RHEL-5-ELS (based on 5.11) are supported.
> 
> RHEL-5.7 isn't supported since 2012-02-09:
> https://pp.engineering.redhat.com/pp/product/rhel/release/rhel-5-7/schedule/
> tasks
> and Satellite Tools were never provided for it.

Didnt know that, thanks. The BZ is irelevant then.

Note You need to log in before you can comment on or make changes to this bug.