Bug 127784 - --arch is broken for up2date
--arch is broken for up2date
Status: CLOSED DUPLICATE of bug 127854
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-13 16:28 EDT by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2004-07-13 16:28:43 EDT
Description of problem:

On RHEL3 for AMD64, with all up2dates,
up2date --arch=x86_64 does work when the i386 version of the package
is already installed:

# rpm -q XFree86-devel --qf '%{ARCH}\n'
i386

# up2date --arch=x86_64 XFree86-devel
...
The following packages you requested are already updated:
XFree86-devel


Yes... I know the *i386* version is installed... but I also want the
x86_64 version!

This works:

# rpm -e XFree86-devel
# up2date --arch=x86_64 XFree86-devel

But then --arch=i386  broken.

up2date (at least the cli version of it) doesn't seem very dual arch
aware :-(
Comment 2 Jeff Needle 2004-08-09 12:04:16 EDT

*** This bug has been marked as a duplicate of 127854 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.
Comment 4 illtud 2006-04-05 12:30:45 EDT
Still an issue for me on an up-to-date RHEL3, and I am not authorized to view
the bug this is a dupe of. What's the fix for me, please? Why is bug 127854 not
public?

Note You need to log in before you can comment on or make changes to this bug.