Bug 1277879 - rhev3.6 should support "folder of files" and "zip" format when select OVA as source while importing vms
rhev3.6 should support "folder of files" and "zip" format when select OVA as ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Unspecified
medium Severity medium
: ovirt-3.6.1
: 3.6.1
Assigned To: Shahar Havivi
Shira Maximov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 05:00 EST by zhoujunqin
Modified: 2016-04-19 21:31 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:31:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot-1 (153.71 KB, image/png)
2015-11-04 05:00 EST, zhoujunqin
no flags Details
Screenshot-2 (157.04 KB, image/png)
2015-11-04 05:02 EST, zhoujunqin
no flags Details
Screenshot-3 (156.52 KB, image/png)
2015-11-04 05:02 EST, zhoujunqin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48129 master MERGED v2v: ova should support zip and extracted directory formats Never
oVirt gerrit 48402 ovirt-3.6 MERGED v2v: ova should support zip and extracted directory formats Never

  None (edit)
Description zhoujunqin 2015-11-04 05:00:47 EST
Created attachment 1089539 [details]
Screenshot-1

Description of problem:
rhev3.6 should support "folder of files" and "zip" format when select OVA as source while importing virtual machine(s)

Version-Release number of selected component (if applicable):
1.
rhevm server: rhevm-3.6.0.2-0.1.el6.noarch
2.
registered host installed with following tree:http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-7.2-20151030.0/compose/Server/x86_64/os/

libvirt-1.2.17-13.el7.x86_64
vdsm-4.17.10-5.el7ev.noarch
libguestfs-1.28.1-1.55.el7.x86_64
virt-v2v-1.28.1-1.55.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Login with administration portal, System->Virtual Machines. 

2. Click Import. Select "Virtual Appliance (OVA)"as source and fill the "Host" and "Path" contents as Screenshot-1.
2.1 On Host path including following 3 kinds format of files.
# ls /opt/
esx-rhel6  esx-rhel6-ova.tar  esx-rhel6-ova.zip
# ls /opt/esx-rhel6
esx-rhel6-disk1.vmdk  esx-rhel6.mf  esx-rhel6.ovf

2.2 In Screenshot-1 testing with file "esx-rhel6-ova.tar".

3. Click the "Load" button.

4. Repeat step2 and step3 with "folder of files" and "zip" format.

Actual results:
1. It works with .tar formation.
2. Failed to get guest configuration with "folder of files" and "zip" format, and get a error:
Failed to load VM configuration from OVA file: /opt/esx-rhel6-ova.zip

See Screenshot-2 and Screenshot-3.

Expected results:
rhev3.6 should support "folder of files" and "zip" format when select OVA as source while importing vms since virt-v2v supports

Additional info:
virt-v2v command works well with "folder of files" and "zip" format and "tar" format.

# virt-v2v -i ova /opt/esx-rhel6/ -o rhev -os 10.66.72.27:/home/nfsexport  -on esx-rhel6-ova-file -of raw

# virt-v2v -i ova  -o rhev -os 10.66.72.27:/home/nfsexport esx-rhel6-ova.zip -on esx-rhel6-ova-zip -of raw 

# virt-v2v -i ova  -o rhev -os 10.66.72.27:/home/nfsexport esx-rhel6-ova.tar -on esx-rhel6-ova-tar -of raw
Comment 1 zhoujunqin 2015-11-04 05:02 EST
Created attachment 1089540 [details]
Screenshot-2
Comment 2 zhoujunqin 2015-11-04 05:02 EST
Created attachment 1089541 [details]
Screenshot-3
Comment 4 Shira Maximov 2016-01-07 10:41:05 EST
nverified on :  Red Hat Enterprise Virtualization Manager Version: 3.6.2-0.1.el6 

verification steps: 
1. yum install virt-v2v on the host 
2. create the ova file. 

for the "folder of files":
create a directory of the un-tar ova file : tar -xvf rhel7.ova 
the folder should contain this files:rhel7-disk1.vmdk  rhel7.mf  rhel7.ovf

[root@dhcp160-245 rhel_7]# pwd
/opt/ova/rhel_7
[root@dhcp160-245 rhel_7]# ls
rhel7-disk1.vmdk  rhel7.mf  rhel7.ovf



for the zip format:
create a directory of the un-tar ova file : tar -xvf rhel7.ova 
the folder should contain this files:rhel7-disk1.vmdk  rhel7.mf  rhel7.ovf
and then create from this file a zip file 
zip rhel.zip rhel7-disk1.vmdk rhel7.mf rhel7.ovf

[root@dhcp160-245 zip]# pwd
/opt/ova/zip
[root@dhcp160-245 zip]# ls
rhel.zip


3. try to import :
1. /opt/ova/zip/rhel.zip
2. /opt/ova/rhel_7


**Note - 
1. this import didn't work without  yum install virt-v2v on the host - should it be mentioned somewhere? and why it is not installed automatically? 
2. importing the zip file and the "folder of files" worked for me only from /opt directory, is that OK ?
Comment 5 Shahar Havivi 2016-01-10 02:05:33 EST
(In reply to Shira Maximov from comment #4)
1. this is a known-issue for 3.6 - and its well documented.
2. you should chown 36:36 to each file and to the zip/folder in order for vdsm have access to the files

Note You need to log in before you can comment on or make changes to this bug.