Bug 1277913 - [meld] version 3.15.0 is broken and produces a backtrace
[meld] version 3.15.0 is broken and produces a backtrace
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
rawhide
noarch Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 05:35 EST by Joachim Frieben
Modified: 2015-12-06 09:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-06 09:08:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2015-11-04 05:35:31 EST
Description of problem:
When meld is launched in order to compare two text files, it simply displays them without any highlighting of existing differences.

Version-Release number of selected component (if applicable):
meld-3.15.0-1.fc24

How reproducible:
Always

Steps to Reproduce:
1. Compare two non-identical text files with meld.

Actual results:
The two text are simply displayed next to each other without any highlighting of actual differences. When launched from the command line, it becomes apparent that a backtrace has been produced by meld.

Expected results:
The two text files are displayed next to each other highlighting any existing difference.

Additional info:
1. Meld version 3.14.1 works as expected in Fedora 23.

2. A backtrace is printed when run from the command line:

"Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/meld/task.py", line 110, in iteration
    ret = next(task)
  File "/usr/lib/python2.7/site-packages/meld/filediff.py", line 1202, in _set_files_internal
    for i in self._diff_files():
  File "/usr/lib/python2.7/site-packages/meld/filediff.py", line 1159, in _diff_files
    while next(step) is None:
  File "/usr/lib/python2.7/site-packages/meld/diffutil.py", line 466, in set_sequences_iter
    while next(work) is None:
  File "/usr/lib/python2.7/site-packages/meld/matchers.py", line 246, in initialise
    a, b = self.preprocess()
  File "/usr/lib/python2.7/site-packages/meld/matchers.py", line 155, in preprocess
    a, b = self.preprocess_remove_prefix_suffix(self.a, self.b)
  File "/usr/lib/python2.7/site-packages/meld/matchers.py", line 109, in preprocess_remove_prefix_suffix
    self.common_prefix = find_common_prefix(a, b)
  File "/usr/lib/python2.7/site-packages/meld/matchers.py", line 43, in find_common_prefix
    if a[0] == b[0]:
  File "/usr/lib/python2.7/site-packages/meld/meldbuffer.py", line 268, in __getitem__
    line_end = line_start.copy()
AttributeError: '_ResultTuple' object has no attribute 'copy'"
Comment 1 Joachim Frieben 2015-12-06 09:08:16 EST
Issue was apparently caused by some other component; not seen in the current Fedora development tree any longer.

Note You need to log in before you can comment on or make changes to this bug.