Bug 1278012 - [GSS] (6.1.z) kie-camel does not load rules when installed in JBoss EAP Module
[GSS] (6.1.z) kie-camel does not load rules when installed in JBoss EAP Module
Status: VERIFIED
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Fuse Integration (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: 6.1.5
Assigned To: Mario Fusco
Jiri Petrlik
Dawn Eisner
:
Depends On: 1276379
Blocks: 1281579 1281586
  Show dependency treegraph
 
Reported: 2015-11-04 09:44 EST by Anton Giertli
Modified: 2016-10-14 10:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1276379
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Mario Fusco 2015-11-25 08:24:31 EST
Cherry-picked to branch 6.2.x with

- drools
https://github.com/droolsjbpm/drools/commit/ee9886aaf

- droolsjbpm-integration
https://github.com/droolsjbpm/droolsjbpm-integration/commit/813508b01523902af34d4107c9b4953a0054fbea
Comment 3 Jiri Petrlik 2015-12-17 03:51:32 EST
Commits with fix are present in BxMS 6.1.5.CR1. However, verification of this bug requires build of integration package. It is because reproducer uses kie-camel from integration package and because BxMS modules for EAP are build with integration pack.
Comment 4 Jiri Petrlik 2016-01-05 10:50:07 EST
Verified using "kie-eap-distributions-bpms-layer-6.2.0.Final-redhat-15". However, it was necessary to make following changes in EAP modules.

1. Add module "org.springframework" from third party libs to EAP.
2. Import module "org.springframework" to module "org.kie" and "org.apache.camel".
3. Add "kie-spring-6.2.0.Final-redhat-15.jar" to "org.kie" module.
4. Add "camel-jaxb-2.14.0.jar" and "camel-spring-2.14.0.jar" to "org.apache.camel" module.
5. Import "org.apache.camel" module to "org.kie".

Moreover, it is necessary to do these changes in reproducer ("sample-kie-service"):

1. The following EAP modules shoud be imported in "jboss-deployment-structure":
  - org.apache.commons.io
  - org.apache.commons.lang3
  - org.springframework
  - org.apache.camel
  - org.kie
  - org.drools
  - javax.xml.bind.api
  - javax.api

2. Bean "kiePolicy" should be commented out from "camel-config.xml".

Note You need to log in before you can comment on or make changes to this bug.