Bug 1278126 - Remove of Cinder disks should remove one volume at a time from the leaf volume up to the base volume.
Remove of Cinder disks should remove one volume at a time from the leaf volum...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Maor
Natalie Gavrielov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 12:27 EST by Maor
Modified: 2016-02-23 08:32 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Removing a Cinder disk might fail because the engine removes all the Cinder disk's volumes/snapshots at the same time and Cinder doesn't support remove of a Cinder volume if it has snapshots which are based on it. Consequence: Disks are failed to be deleted from Cinder Fix: Implementing a recursive way to remove Cinder volumes. As part of this implementation the behavior should be as follow: When trying to remove a Cinder disk we aggregate all the volumes of the Cinder disk, snapshots and Cinder volumes (commited snapshots). Then we execute them one at a time, if there is a failure in the middle we change the disk status to illegal and fail the command. Once an illegal Cinder disk is being removed we only remove the Cinder disk and its volumes from the DB, without removing it from the Cinder provider.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 08:32:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
ylavi: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46042 master MERGED core: Support recursive remove of cinder volumes. Never
oVirt gerrit 47985 master MERGED core: Support remove for Cinder volume. Never
oVirt gerrit 48225 master MERGED core: Audit log on remove disk should be on failure. Never
oVirt gerrit 48234 ovirt-engine-3.6 MERGED core: Support remove for Cinder volume. Never
oVirt gerrit 48235 ovirt-engine-3.6 MERGED core: Support recursive remove of cinder volumes. Never
oVirt gerrit 48236 ovirt-engine-3.6 MERGED core: Audit log on remove disk should be on failure. Never

  None (edit)
Description Maor 2015-11-04 12:27:58 EST
Description of problem:
Removing a Cinder disk should remove all the Cinder disk's volumes.
Each one of the volumes by a specific order (From the leaf volume to the base volume).
The reason the order of the Cinder volumes is so crucial, is that Cinder, doesn't support remove of a Cinder volume if it has snapshots which are based on it.

Version-Release number of selected component (if applicable):
3.6

How reproducible:
50%

Steps to Reproduce:
1. Try to remove a disk with many snapshots
2.
3.

Actual results:
Some of the volumes will fail to be deleted.

Expected results:
The disk should be deleted.

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-05 08:19:30 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Note You need to log in before you can comment on or make changes to this bug.