Bug 1278132 - [Docs] [Director] Duplicate ExternalInterfaceDefaultRoute defined in section 6.2.5.2 of Installation Guide
[Docs] [Director] Duplicate ExternalInterfaceDefaultRoute defined in section ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y2
: 7.0 (Kilo)
Assigned To: Dan Macpherson
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 12:42 EST by Dan Sneddon
Modified: 2016-08-16 02:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-16 02:19:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Sneddon 2015-11-04 12:42:47 EST
Description of problem:
The ExternalInterfaceDefaultRoute is defined twice in the example network-environment.yaml in the official installation guide section 6.2.5.2.

Version-Release number of selected component (if applicable):
OSP 7.1 docs

Actual results:
parameter_defaults:
  ExternalNetCidr: 10.1.1.0/24
  ExternalAllocationPools: [{'start': '10.1.1.2', 'end': '10.1.1.50'}]
  ExternalNetworkVlanID: 100
  ExternalInterfaceDefaultRoute: 10.1.1.1
  # Set to the router gateway on the external network
  ExternalInterfaceDefaultRoute: 10.1.1.1

Expected results:
  ExternalInterfaceDefaultRoute: 10.1.1.1 should only be defined once

Additional info:
  Since declaring a parameter default more than once will result in the value being overwritten, this could lead to unexpected behavior if the user doesn't notice the duplication.
Comment 2 Andrew Dahms 2015-12-03 19:04:37 EST
Assigning to Dan for review.

Note You need to log in before you can comment on or make changes to this bug.