This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1278134 - [abrt] rpmconf: subprocess.py:620:check_output:subprocess.CalledProcessError: Command '['/usr/bin/ls', '-ltrd', '/etc/krb5.conf', '/etc/krb5.conf.rpmnew']' returned non-zero exit status 2
[abrt] rpmconf: subprocess.py:620:check_output:subprocess.CalledProcessError:...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmconf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:0a6be17d4fc1c1a67932d413238...
:
: 1238356 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 12:48 EST by Karel Volný
Modified: 2015-11-27 13:22 EST (History)
3 users (show)

See Also:
Fixed In Version: rpmconf-1.0.13-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 13:22:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.41 KB, text/plain)
2015-11-04 12:48 EST, Karel Volný
no flags Details
File: environ (2.14 KB, text/plain)
2015-11-04 12:48 EST, Karel Volný
no flags Details

  None (edit)
Description Karel Volný 2015-11-04 12:48:09 EST
Description of problem:
I've merged changes with kdiff3, it crashed after saving the changes and closing kdiff3

Version-Release number of selected component:
rpmconf-1.0.12-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /usr/sbin/rpmconf -a -f kdiff3
executable:     /usr/sbin/rpmconf
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
subprocess.py:620:check_output:subprocess.CalledProcessError: Command '['/usr/bin/ls', '-ltrd', '/etc/krb5.conf', '/etc/krb5.conf.rpmnew']' returned non-zero exit status 2

Traceback (most recent call last):
  File "/usr/sbin/rpmconf", line 63, in <module>
    main()
  File "/usr/sbin/rpmconf", line 60, in main
    rconf.run()
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 90, in run
    self._handle_package(pkg_hdr)
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 264, in _handle_package
    tmp.format(conf_file, "rpmnew"))
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 290, in _handle_rpmnew
    self._ls_conf_file(conf_file, other_file)
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 212, in _ls_conf_file
    universal_newlines=True))
  File "/usr/lib64/python3.4/subprocess.py", line 620, in check_output
    raise CalledProcessError(retcode, process.args, output=output)
subprocess.CalledProcessError: Command '['/usr/bin/ls', '-ltrd', '/etc/krb5.conf', '/etc/krb5.conf.rpmnew']' returned non-zero exit status 2

Local variables in innermost frame:
timeout: None
kwargs: {'universal_newlines': True}
popenargs: (['/usr/bin/ls', '-ltrd', '/etc/krb5.conf', '/etc/krb5.conf.rpmnew'],)
retcode: 2
process: <subprocess.Popen object at 0x7f81d81397f0>
inputdata: None
output: '-rw-r--r--. 1 root root 600  4.\xa0lis 13.08 /etc/krb5.conf\n'
unused_err: None
Comment 1 Karel Volný 2015-11-04 12:48:14 EST
Created attachment 1089823 [details]
File: backtrace
Comment 2 Karel Volný 2015-11-04 12:48:15 EST
Created attachment 1089824 [details]
File: environ
Comment 3 Miroslav Suchý 2015-11-04 15:09:40 EST
Aha, this happen when /etc/krb5.conf.rpmnew does not exist.
Comment 4 Miroslav Suchý 2015-11-08 03:40:23 EST
Fixed in upstream in commit:
* 138e42f (HEAD -> master, origin/master, origin/HEAD) 1278134 - do TB when somebody remove file under our hand
Comment 5 Fedora Update System 2015-11-18 09:11:11 EST
rpmconf-1.0.13-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f5cd12f54a
Comment 6 Fedora Update System 2015-11-19 10:26:32 EST
rpmconf-1.0.13-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmconf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f5cd12f54a
Comment 7 Fedora Update System 2015-11-19 11:55:08 EST
rpmconf-1.0.13-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmconf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f5cd12f54a
Comment 8 Miroslav Suchý 2015-11-27 03:07:48 EST
*** Bug 1238356 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2015-11-27 13:22:11 EST
rpmconf-1.0.13-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.