Bug 1278230 - Filezilla fails to start due to relocation error
Filezilla fails to start due to relocation error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: filezilla (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 20:48 EST by trevor
Modified: 2015-12-12 05:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-12 05:46:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description trevor 2015-11-04 20:48:37 EST
Description of problem:


Version-Release number of selected component (if applicable):
# dnf info filezilla
Last metadata expiration check performed 0:17:10 ago on Thu Nov  5 12:21:15 2015.
Installed Packages
Name        : filezilla
Arch        : x86_64
Epoch       : 0
Version     : 3.12.0.2
Release     : 1.fc23
Size        : 15 M
Repo        : @System
From repo   : @commandline
Summary     : FTP, FTPS and SFTP client
URL         : http://filezilla-project.org/
License     : GPLv2+


How reproducible:
Always

Steps to Reproduce:
1. At command prompt invoke "filezilla"
2.
3.

Actual results:
~$ filezilla
filezilla: relocation error: filezilla: symbol _ZThn792_N17wxGenericListCtrl31GetSizeAvailableForScrollTargetERK6wxSize, version WXU_3.0 not defined in file libwx_gtk3u_core-3.0.so.0 with link time reference


Expected results:
Filezilla starts

Additional info:
Comment 1 Nicolas Chauvet (kwizart) 2015-12-12 05:46:50 EST
Fixed with wxGTK3-3.0.2-11.fc23
Please note that you are missing a dnf distro-sync command in your upgrade procedure which is the exact reason why you have hit this issue.
(the wxGTK3 failed to build with f23 because of missing dependencies, and you have the f21 or f22 version with old c++ abi over the f23 older version using the new c++ abi.

Note You need to log in before you can comment on or make changes to this bug.