Bug 127827 - ddcProbe behaviour for powerpc
ddcProbe behaviour for powerpc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-14 08:45 EDT by Paul Nasrat
Modified: 2014-03-16 22:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.1.73-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 15:18:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Nasrat 2004-07-14 08:45:01 EDT
Description of problem:

ddcprobe as in kudzu/ddcprobe works fine on powerpc - using
/proc/device-tree.

However kudzu.probe using ddcProbe does not do the same, although the
Makefile bundles up the vbe.o, of.o, etc. for powerpc

Version-Release number of selected component (if applicable):

cvs HEAD

How reproducible:


Steps to Reproduce:
1. As root
2. python -c "import kudzu; print kudzu.probe(kudzu.CLASS_MONITOR,
kudzu.BUS_DDC, kudzu.PROBE_ALL)

  
Actual results:
[]

Expected results:
[Desc:           iMac
Id:             APP059d
Mem on card:    0
HSync:          60-60
VSync:          75-117
Physical width: 270 mm
Physical height: 200 mm
]


Additional info:

I'm not sure if this is by design or not, but it'd be nice to be able
to get the right values for mac installs, etc.  I tested by
s/__i386__/__powerpc__/ and adding VBEL in ddc.c, built cp kudzu.py
python23/, cd python23 and run python fragment above.
Comment 1 Bill Nottingham 2004-07-14 15:14:29 EDT
Hrm, it was supposedly working.
Comment 2 Bill Nottingham 2004-07-14 15:18:27 EDT
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.