Bug 127837 - warnings 2.6.7-1.486 usb drivers compiled in
Summary: warnings 2.6.7-1.486 usb drivers compiled in
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-14 15:39 UTC by Brian Millett
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-16 10:41:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Millett 2004-07-14 15:39:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040705 Firefox/0.9.0+

Description of problem:
Well, I'm not sure if this is a bug, or a kernel change.  But I get an
error at boot because the following modules can not be loaded/found:
uhci_hcd
ehci_hcd
usb_ohci

I did a quick check to see if the modules were in the last couple of
kernel releases:
./2.6.7-1.478/kernel/drivers/usb/host/ehci-hcd.ko
./2.6.7-1.478/kernel/drivers/usb/host/ohci-hcd.ko
./2.6.7-1.478/kernel/drivers/usb/host/uhci-hcd.ko
./2.6.7-1.481/kernel/drivers/usb/host/ehci-hcd.ko
./2.6.7-1.481/kernel/drivers/usb/host/ohci-hcd.ko
./2.6.7-1.481/kernel/drivers/usb/host/uhci-hcd.ko

Looks like nothing for kernel 486.

Is this a feature?  I do not seem to have lost any functionality.  I
just checked and see that they are compiled into the kernel:
#
# USB Host Controller Drivers
#
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_EHCI_SPLIT_ISO=y
CONFIG_USB_EHCI_ROOT_HUB_TT=y
CONFIG_USB_OHCI_HCD=y
CONFIG_USB_UHCI_HCD=y


So is this the plan?

Thanks.

Version-Release number of selected component (if applicable):
 2.6.7-1.486

How reproducible:
Always

Steps to Reproduce:
1.boot
2.select kernel 486
3.
    

Additional info:

Comment 1 Warren Togami 2004-07-14 21:22:31 UTC
This really isn't a problem, although initscripts could probably be
fixed to no longer display an error message.

Comment 2 Warren Togami 2004-07-16 10:41:40 UTC
USB has been changed back to modules in kernel 492 after Alan Cox's
fix  made it safe to do, so this is no longer a bug.


Note You need to log in before you can comment on or make changes to this bug.