Bug 127838 - sleeping function called from invalid context
sleeping function called from invalid context
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-14 11:41 EDT by H.J. Lu
Modified: 2015-01-04 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 20:09:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2004-07-14 11:41:16 EDT
During boot, kernel 2.6.7-1.486 gave

Debug: sleeping function called from invalid context at mm/mempool.c:197
in_atomic():0[expected: 0], irqs_disabled():1
 [<0211f978>] __might_sleep+0x7d/0x87
 [<0213f92b>] mempool_alloc+0x6a/0x198
 [<0214421e>] poison_obj+0x1d/0x3d
 [<0211ff27>] autoremove_wake_function+0x0/0x2d
 [<021459ba>] cache_alloc_debugcheck_after+0xcf/0x103
 [<0211ff27>] autoremove_wake_function+0x0/0x2d
 [<0213f93c>] mempool_alloc+0x7b/0x198
 [<02220d6c>] __cfq_get_queue+0x53/0x98
 [<02220e00>] cfq_get_queue+0x4f/0x86
 [<022210cd>] cfq_set_request+0x20/0x63
 [<022210ad>] cfq_set_request+0x0/0x63
 [<0221823f>] elv_set_request+0xa/0x17
 [<02219dba>] get_request+0x18b/0x2b0
 [<02219f5c>] get_request_wait+0x7d/0xb9
 [<0211ff27>] autoremove_wake_function+0x0/0x2d
 [<0214421e>] poison_obj+0x1d/0x3d
 [<0211ff27>] autoremove_wake_function+0x0/0x2d
 [<02219faf>] blk_get_request+0x17/0x1e
 [<0221d2c9>] sg_scsi_ioctl+0x135/0x295
 [<0214d4e6>] do_anonymous_page+0x1fa/0x23e
 [<0213e058>] filemap_nopage+0x187/0x2ef
 [<0221d710>] scsi_cmd_ioctl+0x2e7/0x37f
 [<0214d58f>] do_no_page+0x65/0x358
 [<0214da39>] handle_mm_fault+0xde/0x1d3
 [<0211a939>] do_page_fault+0x172/0x57a
 [<0214e7b6>] __vma_link+0x59/0x66
 [<2201f88e>] sd_ioctl+0x87/0xa6 [sd_mod]
 [<0221bf59>] blkdev_ioctl+0x33c/0x349
 [<02164026>] block_ioctl+0x11/0x13
 [<0216d3da>] sys_ioctl+0x239/0x29c
 [<022dfefc>] __cond_resched+0x14/0x39
Comment 1 Kaj J. Niemi 2004-07-14 12:13:18 EDT
Looks similar to bug #127615.
Comment 2 Markku Kolkka 2004-07-16 05:28:43 EDT
I'm getting several similar debug messages in the system log, but the
call trace is different:
Jul 16 11:13:38 nightshade kernel: Debug: sleeping function called
from invalid context at mm/mempool.c:197
Jul 16 11:13:38 nightshade kernel: in_atomic():0[expected: 0],
irqs_disabled():1
Jul 16 11:13:38 nightshade kernel:  [<0211c5f8>] __might_sleep+0x7d/0x89
Jul 16 11:13:38 nightshade kernel:  [<02140fad>] mempool_alloc+0x6a/0x245
Jul 16 11:13:38 nightshade kernel:  [<0211cc89>]
autoremove_wake_function+0x0/0x2d
Jul 16 11:13:38 nightshade kernel:  [<0211cc89>]
autoremove_wake_function+0x0/0x2d
Jul 16 11:13:38 nightshade kernel:  [<02140fbe>] mempool_alloc+0x7b/0x245
Jul 16 11:13:38 nightshade kernel:  [<022396dc>] __cfq_get_queue+0x53/0x98
Jul 16 11:13:38 nightshade kernel:  [<022397da>] cfq_get_queue+0xb9/0x137
Jul 16 11:13:38 nightshade kernel:  [<02239ae8>] cfq_set_request+0x20/0x63
Jul 16 11:13:38 nightshade kernel:  [<02239ac8>] cfq_set_request+0x0/0x63
Jul 16 11:13:38 nightshade kernel:  [<02230a27>] elv_set_request+0xa/0x17
Jul 16 11:13:38 nightshade kernel:  [<022324c8>] get_request+0x281/0x44e
Jul 16 11:13:39 nightshade kernel:  [<02232712>]
get_request_wait+0x7d/0xb9
Jul 16 11:13:39 nightshade kernel:  [<0211cc89>]
autoremove_wake_function+0x0/0x2d
Jul 16 11:13:39 nightshade kernel:  [<0211cc89>]
autoremove_wake_function+0x0/0x2d
Jul 16 11:13:39 nightshade kernel:  [<022333e8>]
__make_request+0x3a4/0x5c3
Jul 16 11:13:39 nightshade kernel:  [<02233797>]
generic_make_request+0x190/0x1a0
Jul 16 11:13:39 nightshade kernel:  [<0223384b>] submit_bio+0xa4/0xac
Jul 16 11:13:39 nightshade kernel:  [<0216612e>] submit_bh+0x5e/0x101
Jul 16 11:13:39 nightshade kernel:  [<0216622a>] ll_rw_block+0x59/0x6e
Jul 16 11:13:39 nightshade kernel:  [<2284d63f>]
journal_commit_transaction+0x8a9/0x1bfa [jbd]
Jul 16 11:13:39 nightshade kernel:  [<0211cc89>]
autoremove_wake_function+0x0/0x2d
Jul 16 11:13:39 nightshade kernel:  [<0211cc89>]
autoremove_wake_function+0x0/0x2d
Jul 16 11:13:39 nightshade kernel:  [<228512d7>] kjournald+0x1ad/0x54f
[jbd]
Jul 16 11:13:39 nightshade kernel:  [<0211cc89>]
autoremove_wake_function+0x0/0x2d
Jul 16 11:13:39 nightshade kernel:  [<0211cc89>]
autoremove_wake_function+0x0/0x2d
Jul 16 11:13:39 nightshade kernel:  [<22851124>]
commit_timeout+0x0/0x5 [jbd]
Jul 16 11:13:39 nightshade kernel:  [<2285112a>] kjournald+0x0/0x54f [jbd]
Jul 16 11:13:39 nightshade kernel:  [<021041d9>]
kernel_thread_helper+0x5/0xb
Comment 3 Warren Togami 2004-07-16 06:12:58 EDT
I've seen this too, and interesting that "cfq" shows up there.  Can
you please test the exact same kernel, using it in the same way,
except booting with either anticipatory or deadline scheduler?

Boot with "elevator=as" or "elevator=deadline" as a kernel option in
order to test this.

Arjan just mentioned to me that a WARN_ON thing relating to this was
broken recently, but since fixed.  That is probably what you see in
the above report.  Indeed this problem seems to have gone away for me
when I upgraded from 486 to 488.  It should be fixed in 492 for sure
though.  Anyhow please test and report back confirmations.

Note You need to log in before you can comment on or make changes to this bug.