Bug 1278386 - 'Installing Boot Loader' step takes too much time
'Installing Boot Loader' step takes too much time
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 06:36 EST by HotMusicFan
Modified: 2015-11-06 14:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-06 14:13:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs archive (518.78 KB, application/zip)
2015-11-06 07:16 EST, HotMusicFan
no flags Details
program.log extracted from anaconda-logs.zip (1.97 MB, text/plain)
2015-11-06 13:58 EST, David Shea
no flags Details
packaging.log extracted from anaconda-logs.zip (207 bytes, text/plain)
2015-11-06 13:58 EST, David Shea
no flags Details
journal.log extracted from anaconda-logs.zip (3.97 MB, text/plain)
2015-11-06 13:58 EST, David Shea
no flags Details
storage.log extracted from anaconda-logs.zip (581.81 KB, text/plain)
2015-11-06 13:58 EST, David Shea
no flags Details
ifcfg.log extracted from anaconda-logs.zip (7.67 KB, text/plain)
2015-11-06 13:58 EST, David Shea
no flags Details
anaconda.log extracted from anaconda-logs.zip (65.92 KB, text/plain)
2015-11-06 13:58 EST, David Shea
no flags Details

  None (edit)
Description HotMusicFan 2015-11-05 06:36:37 EST
Hello!

First I have experienced this problem in the previous versions of Fedora too (20, 21, 22) but for some reason I have never reported it.
When installing Fedora Anaconda takes too much time to perform the step 'Installing Boot Loader'. It installs the software for about 4-6 minutes, for the bootloader it takes approx. 40-50 minutes (!!!) and one or two to finish with initramfs and running the post-installation scripts. 
This makes the installation experience horrible. 
If this matters I have UEFI based hardware with secure boot disabled, I make clean installations every time and I am using KDE live CDs copied to USB Flash drive.
Please tell me if this is really a bug or it is something with my environment.

Thanks :)
Comment 1 David Shea 2015-11-05 09:41:34 EST
Please attach the logs from the install to this bug as individual, text/plain attachments. The log files are available in /tmp during the install and copied to /var/log/anaconda in the installed system.
Comment 2 HotMusicFan 2015-11-06 07:16 EST
Created attachment 1090649 [details]
Logs archive

Here are the logs.
Comment 3 David Shea 2015-11-06 13:58:11 EST
Created attachment 1090773 [details]
program.log extracted from anaconda-logs.zip
Comment 4 David Shea 2015-11-06 13:58:15 EST
Created attachment 1090774 [details]
packaging.log extracted from anaconda-logs.zip
Comment 5 David Shea 2015-11-06 13:58:36 EST
Created attachment 1090775 [details]
journal.log extracted from anaconda-logs.zip
Comment 6 David Shea 2015-11-06 13:58:42 EST
Created attachment 1090776 [details]
storage.log extracted from anaconda-logs.zip
Comment 7 David Shea 2015-11-06 13:58:46 EST
Created attachment 1090777 [details]
ifcfg.log extracted from anaconda-logs.zip
Comment 8 David Shea 2015-11-06 13:58:50 EST
Created attachment 1090778 [details]
anaconda.log extracted from anaconda-logs.zip
Comment 9 David Shea 2015-11-06 14:13:02 EST
While installing the bootloader on UEFI systems, anaconda will remove any previous UEFI firmware entries for Fedora, and then add the new one. The problem is that you had 288 previous entries for Fedora. I have no idea what caused that. Maybe an old bug in efibootmgr or anaconda, maybe a bug in your firmware. Anyway, you should be down to one now.
Comment 10 HotMusicFan 2015-11-06 14:25:14 EST
I see. I have this machine since two years and the first installation on it was with Fedora 19 - it is impossible since then to have so many reinstalls and resp. so many entries. How can I check how many entries there are in UEFI before (or during) the installation? Or now, on an installed system?
Comment 11 David Shea 2015-11-06 14:30:43 EST
Running "efibootmgr" with no arguments will display the current efi boot settings.
Comment 12 HotMusicFan 2015-11-06 14:34:33 EST
Thank you very much!

Note You need to log in before you can comment on or make changes to this bug.