Bug 127847 - Sound broken in KDE, but works in Gnome and at the console
Sound broken in KDE, but works in Gnome and at the console
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-14 14:04 EDT by Scott Baker
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: fc3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 15:46:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Baker 2004-07-14 14:04:38 EDT
I have a Fedora Core 2 box at work that has VIA on-board audio that I
can't seem to get to work. Although the problem seems to persist with
another sound card also. I know all about ALSA and audio levels etc,
but I can't for the life of me get audio under KDE to work.

The strange thing is if I boot the box into runlevel 3 and use mpg321
to play an MP3 it works just fine. In fact if I got into runlevel 5
and load Gnome instead of KDE audio still works. As soon as I boot
into KDE sound get hosed up and nothing will play. No error message,
just no sound from the speakers. I've tripple checked the volume
levels and still no luck. Booting into Gnome, adjusting volume levels,
playing sound works, immediately booting into KDE same volume levels,
playing sounds doens't work.

Logic would dictate that arts is just causing some strange problem, so
I disabled arts all together and still no sound. While sound is
"supposedly" playing, if I turn up the volume real loud I can hear a
pop every so often that's not there when sound isn't playing, but
that's the most I get. There is no: artsd, esd, esound, etc daemons
running. Sound just refuses to work in KDE. In fact if I boot into
Gnome, play sound (it works), then boot into KDE with broken sound and
go back into Gnome it's stays hosed. KDE is doing something funky to
the soundcard. After loading KDE the *ONLY* way to get sound working
again is to reboot (not even runlevel 1 fixes the problem).

So basically sound is working fine everywhere except the place that I
need it! I've tried different kernels, as well the new KDE 3.2.3
thinking it was KDE. No luck!
Comment 1 Ngo Than 2004-09-26 19:37:56 EDT
could you please start alsamixer and aumix to adjust the volume. if it
does not work, please try to reset your sound seting in
kcontrol->Sound & Multimedia->Sound System-> Default button.

Perhaps you should try with "select the audio device -> Advanced Linux
Sound Architecture".

Comment 2 Scott Baker 2004-09-30 11:10:02 EDT
I restarted Alsa, and checked all the levels everything appears
normal. After a reboot, and then loading Gnome sounds works just fine.
If I boot into KDE all I get are really quiet pops from my speakers.
Comment 3 Christopher Stone 2004-10-20 17:40:31 EDT
KDE resets volume to zero on startup, see bug 136543
Comment 4 Scott Baker 2004-12-03 19:06:09 EST
The exact same system seems to work just fine (audio wise) with FC3. I
have no idea what changed, but now I am able to get audio again.
Comment 5 Matthew Miller 2005-04-26 11:51:50 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 6 John Thacker 2006-10-25 15:46:16 EDT
Since it seems to work fine with FC3 and FC2 is not supported even by Fedora
Legacy, closing.

Note You need to log in before you can comment on or make changes to this bug.