Bug 1278474 - Adding hosts to wrong cluster results in deploy loop that you can't stop until you reboot engine
Adding hosts to wrong cluster results in deploy loop that you can't stop unti...
Status: CLOSED DUPLICATE of bug 1279625
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.1
: ---
Assigned To: Eli Mesika
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 09:58 EST by Bill Sanford
Modified: 2016-02-10 14:14 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 08:43:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.z?
rule-engine: planning_ack?
bsanford: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
Host deploy log on the engine (360.62 KB, text/plain)
2015-11-05 09:58 EST, Bill Sanford
no flags Details
Engine log (506.09 KB, application/x-gzip)
2015-11-05 14:11 EST, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2015-11-05 09:58:06 EST
Created attachment 1090136 [details]
Host deploy log on the engine

Description of problem:
I tried to add a different arch of processor (AMD Phenom(tm) II X4 820 Processor) to a cluster that supported the AMD Opteron G1 and the whole host was installed and at the end of the install the host error:

First the host displayed: "Status of host kaitain was set to Up."

Second the host displayed: "Host kaitain is compatible with versions (3.0,3.1) and cannot join Cluster DC35Cluster which is set to version 3.5."

This cycled about every 3 seconds, it couldn't be stopped and it really bogged down the engine. The only way I could stop it was to reboot the RHEV-M engine.


Version-Release number of selected component (if applicable):
RHEL-6.7-20150811.1 & RHEV-M 3.6.0-17

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
The host gets fully installed and hits a fail loop.

Expected results:
The host should not be installed and stopped as soon as RHEV-M knows it's not compatible.

Additional info:
Comment 1 Alon Bar-Lev 2015-11-05 10:09:16 EST
host-deploy is ok.

please attach engine.log.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-05 10:09:20 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-05 10:09:20 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 4 Bill Sanford 2015-11-05 14:11 EST
Created attachment 1090316 [details]
Engine log
Comment 5 Moti Asayag 2015-11-10 08:43:18 EST
The scenario is the same as bug 1278474 : a host is being installed into incompatible cluster version.

*** This bug has been marked as a duplicate of bug 1279625 ***

Note You need to log in before you can comment on or make changes to this bug.