This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1278527 - Editing any plan options in the Global Configuration malforms the plan json
Editing any plan options in the Global Configuration malforms the plan json
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 12:12 EST by Jason Montleon
Modified: 2016-04-18 02:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 12:27:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Montleon 2015-11-05 12:12:34 EST
Description of problem:
I have tried editing the Compute-1::AdminPasswd and Compute-1::NeutronPublicInterface on separate occasions. In both instances it made it impossible to deploy the overcloud.

Steps to Reproduce:
1. Set up an undercloud
2. Change an option in the global config
3. try to deploy

Actual results:
Receive error: Unable to deploy overcloud. Reason: Value must be valid JSON: Expecting property name enclosed in double quotes: line 1 column 2 (char 1)

Expected results:
Deployment actually works
Comment 2 Jason Montleon 2015-11-05 12:16:46 EST
should clarify that these edits were performed through the web ui. it seems the CLI and API work,
Comment 3 chris alfonso 2015-11-11 12:27:38 EST
We will not be fixing the webui as we are going to remove it entirely.

Note You need to log in before you can comment on or make changes to this bug.