Bug 1278594 - kickstart with ks=hd:sda2:/fedora/ks.cfg is not working
kickstart with ks=hd:sda2:/fedora/ks.cfg is not working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 1278593 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 17:22 EST by Guido
Modified: 2015-11-06 11:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-06 11:36:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guido 2015-11-05 17:22:11 EST
Fedora 23, with workstation-netinst iso, will not even start a kickstart install. The only change in my ks.cfg is 22 -> 23. The iso boots (both DVD & USB stick), media check is good. I hit <Esc> & do my usual command at the boot prompt

     linux ks=hd:sda2:/fedora/ks.cfg

which has worked for many years & with many many releases.

I immediately get the familiar GUI install screen demanding the usual manual or test or troubleshoot install actions. It seems that ANYthing entered after the 'boot:' prompt is simply ignored.

I have also tried some variants

    linux inst.ks=...

inserting inst. as a prefix in the ks.cfg file; it's NOT clear which statements require this.

Nothing works AND there are NO error messages displayed.

Something is badly awry or maybe the rules for kickstart have changed?
Comment 1 Brian Lane 2015-11-05 19:57:18 EST
*** Bug 1278593 has been marked as a duplicate of this bug. ***
Comment 2 Brian Lane 2015-11-05 20:04:33 EST
To edit the cmdline when booting the iso on BIOS you:

1. Hit Tab
2. Edit the cmdline to add ks=hd:sda2:/fedora/ks.cfg
3. Hit Enter

You should see the kernel and initrd load and anaconda start running. Does this happen?

Or are you hitting ESC at some point while editing? This will return you to the menu and remove any edits you have made.

And FYI the inst. prefix is still optional. ks or inst.ks will work.

If you get to the point where Anaconda is running and it still isn't working please attach the logs from /tmp/*log as individual text/plain attachments.
Comment 3 Guido 2015-11-05 21:59:32 EST
(In reply to Brian Lane from comment #2)
> To edit the cmdline when booting the iso on BIOS you:
> 
> 1. Hit Tab
> 2. Edit the cmdline to add ks=hd:sda2:/fedora/ks.cfg
> 3. Hit Enter
> 
> You should see the kernel and initrd load and anaconda start running. Does
> this happen?
> 
> Or are you hitting ESC at some point while editing? This will return you to
> the menu and remove any edits you have made.
> 
> And FYI the inst. prefix is still optional. ks or inst.ks will work.
> 
> If you get to the point where Anaconda is running and it still isn't working
> please attach the logs from /tmp/*log as individual text/plain attachments.

It works! BUT, where in the Fedora 23 docs does it describe the ENTIRELY new procedure? I did peruse the docs before my complaint & did again after your suggestion. "We" need to do much better on documenting these sorts of changes.

However, I have another problem. This worked before. I'm trying to install to an ext4 partition already formatted. Screen hangs & says "Error checking storage configuration". Must I let kickstart make a new partition/file system in F23? Please advise. Thanks.
Comment 4 Guido 2015-11-05 23:24:47 EST
Addendum. The <Esc> key should NOT yield a "boot: " prompt. Very confusing.
Comment 5 Guido 2015-11-06 01:30:41 EST
My entire install of F23 is now complete & successful.

Another change. --noformat causes errors in the part statement. The installer insists on doing a fresh mkfs.whatever. Perhaps, this, too, should be added to the documentation.
Comment 6 Brian Lane 2015-11-06 11:36:45 EST
Anaconda needs a fresh / partition so formatting it is required. None of this behavior has changed recently.

Note You need to log in before you can comment on or make changes to this bug.