This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1278687 - Lack of firewall / iptables specification between master and node
Lack of firewall / iptables specification between master and node
Status: CLOSED NEXTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
https://access.redhat.com/documentati...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 02:28 EST by Naoya Hashimoto
Modified: 2017-03-08 13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-15 19:44:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naoya Hashimoto 2015-11-06 02:28:17 EST
Document URL: 
https://access.redhat.com/documentation/en/openshift-enterprise/version-3.0/openshift-enterprise-30-architecture/architecture

Section Number and Name: 
CHAPTER 2. INFRASTRUCTURE COMPONENTS

Describe the issue: 
No specification or requirement about firewall or iptables are provided at OSEv3 and it makes hard to understand which ports the components or processes of openshift-master and openshift-node require when we need to troubleshoot about communication problem or tell if it is caused by firewall or iptables.

Suggestions for improvement: 
OSEv2 provides specification of firewall and iptables.
It would be nicer to add such information in the OSEv3 documentation.

Additional information: 
Cf. Table 5.1. Required Ports for OpenShift Enterprise
<https://access.redhat.com/documentation/en-US/OpenShift_Enterprise/2/html-single/Deployment_Guide/#Custom_and_External_Firewalls>
Comment 2 Kenjiro Nakayama 2015-11-08 23:43:41 EST
Upstream (origin doc) has already been merged.

https://github.com/openshift/openshift-docs/pull/1136
https://docs.openshift.org/latest/admin_guide/available_ports.html

I think it will be synced to OSE doc very soon.
Comment 4 Naoya Hashimoto 2015-11-09 00:47:42 EST
That will be great. 
Look forward to the merge.Thanks.
Comment 5 Naoya Hashimoto 2015-11-12 22:25:45 EST
The following page was available, but not right now.
https://docs.openshift.org/latest/admin_guide/available_ports.html
The page is moved or deleted?
Comment 9 Naoya Hashimoto 2015-11-15 19:38:14 EST
Thanks, I confirmed the page is moved into the above section.

Note You need to log in before you can comment on or make changes to this bug.