Bug 1278702 - [RFE] Citrix Xenserver as a compute resource in Satellite 6
[RFE] Citrix Xenserver as a compute resource in Satellite 6
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources (Show other bugs)
6.1.3
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 03:45 EST by Prakash Ghadge
Modified: 2017-05-03 02:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-30 09:59:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 Prakash Ghadge 2015-12-08 12:09:17 EST
Cu words 

~~~

I have gotten authentication to work on the command line, using:

# cat /etc/libvirt/auth.conf
[credentials-endor]
username=root
password=<password>

[auth-libvirt-192.168.60.82]
credentials=endor


But now another problem has appeared...

Satellite 6 seems to be implementing the OLD API.. "virConnectOpen".. and not the new "virConnectOpenAuth"... which is needed for authentication, as far as I understand from the libvirt developers...
~~~
Comment 7 Prakash Ghadge 2015-12-08 12:10:33 EST
Cu. words
~~~
If I set the credentials in /etc/libvirt/auth.conf and make attached change/hack to:

/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.24.0/lib/fog/libvirt/compute.rb

Basically forcing use of the open_auth method... then I can connect to XenServer....

Now i'm faced with a new error... in the "Virtual Machines" tab:

There was an error listing VMs: Call to virDomainAutostart failed: An error occurred, but the cause is unknown

Could be related to this older bug:

https://github.com/fog/fog/issues/2002
~~~
Comment 8 Martin Juhl 2016-01-27 11:02:12 EST
Any idea when this RFE will be handled???

Regards
Comment 11 Bryan Kearney 2017-01-30 09:59:02 EST
We do not have plans to support this in the near future, so I am closing this out. You are free to use the community plugin with your version of Satellite6 to achieve this goal. If you have any concerns, please feel free to contact myself or Todd Warner.

Note You need to log in before you can comment on or make changes to this bug.