Bug 1278720 - Improve error message on incorrect Foreman credentials
Improve error message on incorrect Foreman credentials
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin (Show other bugs)
6.1.4
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 04:30 EST by Sachin Ghai
Modified: 2017-01-05 10:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-05 10:57:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12412 None None None 2016-04-22 12:50 EDT

  None (edit)
Description Sachin Ghai 2015-11-06 04:30:54 EST
Description of problem:

I was trying pxe-less discovery via external capsule and using FDI image "fdi-bootable-3.0.4.iso".

Steps to reproduce:

1. boot the VM/host using unmodified ISO
2. select the Manual network configuration option since dhcp feature was disabled on capsule.
3. on Foreman Credentials screen
a) Specify the URL
b) select connection-type 'Server' instead of 'Proxy'

Ideally user should get an error but user successfully moved to next "Custom Facts" screen. And on clicking 'Confirm' button', first screen "Manual Pxe-less workflow" appears.

Note: In case user enters incorrect URL with incorrect domain or without any port then also user should get an error.


Build ver:
--------
Satellite 6.1.4 compose3

on capsule:
rubygem-smart_proxy_discovery-1.0.3-1.el7sat.noarch

on sat6 server:
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
rubygem-smart_proxy_discovery-1.0.3-1.git.0.3a55100.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.20-1.el7sat.noarch

Image: fdi-bootable-3.0.4.iso
Comment 1 Sachin Ghai 2015-11-06 04:31:18 EST
Upstream issue filed: http://projects.theforeman.org/issues/12412
Comment 3 Lukas Zapletal 2015-11-11 02:52:03 EST
Not a blocker, I propose this for 6.2.
Comment 4 Bryan Kearney 2017-01-05 10:57:08 EST
This is an older bug which has been reported upstream. We are not going to track this bug downstream. When the upstream issue is resolved, the next build will contain the fix. Thank you.

Note You need to log in before you can comment on or make changes to this bug.