Bug 1278816 - mock does not log creation of root with tmpfs plugin
mock does not log creation of root with tmpfs plugin
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 08:38 EST by Lukas Slebodnik
Modified: 2016-03-08 09:34 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 09:34:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log without enabled tmpfs (354.89 KB, text/plain)
2015-11-06 08:39 EST, Lukas Slebodnik
no flags Details
root.log WITH enabled tmpfs plugin (167.58 KB, text/plain)
2015-11-06 08:39 EST, Lukas Slebodnik
no flags Details

  None (edit)
Description Lukas Slebodnik 2015-11-06 08:38:16 EST
Description of problem:
If tmpfs plugin is enabled then it is harder to find issue with installation of basic packages in chroot. Because the root.log file does not contain any messages. So it is not clear what failed.

Version-Release number of selected component (if applicable):
mock-1.2.13-2.fc22

How reproducible:
Deterministic

Steps to Reproduce:
1. Enable tmpfs plugin in mock configuration
sh# cat >> /etc/mock/site-defaults.cfg <<EOF
config_opts['plugin_conf']['tmpfs_enable'] = True
config_opts['plugin_conf']['tmpfs_opts']['required_ram_mb'] = 1536
config_opts['plugin_conf']['tmpfs_opts']['max_fs_size'] = '1536m'
EOF

2. Try to rebuild some pacakge
wget https://kojipkgs.fedoraproject.org//packages/sssd/1.13.1/4.fc24/src/sssd-1.13.1-4.fc24.src.rpm
mock --rebuild sssd-1.13.1-4.fc24.src.rpm --resultdir .


Actual results:
root.log does not contain details about installation of basic packages in chroot.
e.g. Executing command: ['/usr/bin/dnf', '--installroot' ... 

Expected results:
The similar output as without enabled tmpfs plugin.

Additional info:
Comment 1 Lukas Slebodnik 2015-11-06 08:39 EST
Created attachment 1090667 [details]
root.log without enabled tmpfs
Comment 2 Lukas Slebodnik 2015-11-06 08:39 EST
Created attachment 1090668 [details]
root.log WITH enabled tmpfs plugin
Comment 3 Lukas Slebodnik 2015-11-06 08:42:24 EST
You can try to see differences between attached file.
diff root.log root_tmpfs.log
Comment 4 Miroslav Suchý 2015-12-21 19:34:33 EST
Hmm I see:
  ['/usr/bin/dnf', '--installroot'
in both files exactly 6 times.

The diff is hard to read and there are differencies in paths so it is quiet verbose.

Can you please clarify which lines exactly you are missing?

Note: we are using tmpfs plugin in Copr and I did not notice any missing part in logs.
Comment 5 Lukas Slebodnik 2016-03-08 09:34:19 EST
I'm sorry for replying so late. It was not a big priority for me. 
I could not find installation of "@buildsys-build" in root_tmpfs.log
But now I realized that it was caused by already created root cache log.
/var/cache/mock/fedora-*-x86_64/root_cache/

I agree it's not a bug.

Note You need to log in before you can comment on or make changes to this bug.