Bug 1278819 - conky 1.10.0 crashes on startup
conky 1.10.0 crashes on startup
Status: CLOSED DUPLICATE of bug 1284232
Product: Fedora
Classification: Fedora
Component: conky (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 08:43 EST by Steven Usdansky
Modified: 2015-12-04 03:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 03:10:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2015-11-06 08:43:28 EST
Description of problem:
conky 1.10.0 crashes on startup

Version-Release number of selected component (if applicable):
conky 1.10.0 

How reproducible:
100%


Steps to Reproduce:
1. run conky
2.
3.

Actual results:
~$ conky
conky: Syntax error (/home/a/.conkyrc:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: desktop window (12000a2) is subwindow of root window (4b4)
conky: window type - normal
conky: drawing to created window (0x3200002)
conky: drawing to double buffer
conky: X Error: type 0 Display 55bde061aa60 XID 52428804 serial 201 error_code 8 request_code 62 minor_code 0 other Display: 55bde061aa60



Expected results:
~/Desktop$ conky
Conky: desktop window (12000a2) is subwindow of root window (4b4)
Conky: window type - normal
Conky: drawing to created window (0x2a00002)
Conky: drawing to double buffer


Additional info:
conky-1.9.0-14.20141003git30d09e.fc23.x86_64 works properly
Comment 1 Miroslav Lichvar 2015-11-06 09:21:01 EST
Does it work when you manually convert the config to the new syntax?
Comment 2 Steven Usdansky 2015-11-07 10:46:04 EST
Display error persists with a new-style .conkyrc. The same new-style .conkyrc file works   fine with conky-1.10.0-1 in Ubuntu 16.04 dev

~$ conky
conky: desktop window (1a000a2) is subwindow of root window (4b4)
conky: window type - normal
conky: drawing to created window (0x3800002)
conky: drawing to double buffer
conky: X Error: type 0 Display 55cc081f4e90 XID 58720260 serial 186 error_code 8 request_code 62 minor_code 0 other Display: 55cc081f4e90

Aborted (core dumped)
Comment 3 Miroslav Lichvar 2015-12-04 03:10:17 EST
A similar error was reported in bug #1284232 and there is a suggestion to enable double-buffering support.

*** This bug has been marked as a duplicate of bug 1284232 ***

Note You need to log in before you can comment on or make changes to this bug.