Bug 1278857 - less Requires: man-db - WHY?
less Requires: man-db - WHY?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: less (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 10:01 EST by Harald Reindl
Modified: 2016-05-07 07:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: less-481-5.fc23 less-481-5.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-26 16:53:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2015-11-06 10:01:07 EST
why in the world pulls "less" man-db explicitly?
see also https://bugzilla.redhat.com/show_bug.cgi?id=1262605

on headless servers with "tsflags=nodocs" in the yum/dnf configuration it makes *zero sense* to pull /usr/bin/man & friends as well it makes no sense to have manpages on each of 35 virtual servers when you can read them fine on the admin machine
Comment 2 Yu Watanabe 2016-03-09 03:19:30 EST
Yeah, please remove the dependencies.

Our cloud servers are installed with tsflags=nodocs option and only less package requires man-db.
Comment 3 Honza Horak 2016-03-09 05:32:24 EST
man dependency was introduced as fix for BZ#1241543, so what we could do is to make the lesspipe.sh script a bit smarter and use man only when available, otherwise use groff as before. Then soft RPM dependency would be valid there -- `Suggests: man` should be sufficient I guess. How does this solution sound to you?
Comment 4 Yu Watanabe 2016-03-10 02:01:44 EST
I see. If man is not available, I think it is enough to output error message like when identify command is not available for pictures files.
Man-db is a mandatory package of core group. So, almost all users are not affected by that change.

Note that "Requires: groff-base" is not necessary if my suggestion is approved.
Comment 5 Yu Watanabe 2016-03-14 22:12:35 EDT
Now I change my mind. Just removing requirements groff-base and man-db from spec file is enough. Because, many commands are used in lesspipe.sh, but these commands excepts man are not required in the spec file.

Anyway, "Requires: groff-base" is completely meaningless. And removing "Requires: man-db" does not affect for almost all users, since, as I said before, man-db is a mandatory package of core group.
Comment 6 Fedora Admin XMLRPC Client 2016-03-24 14:01:09 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Pavel Raiskup 2016-04-20 04:03:11 EDT
Fixed in Rawhide, can anybody check that it makes sense?
http://pkgs.fedoraproject.org/cgit/rpms/less.git/commit/?id=6dde17a8465c3f7c75d18d61
Comment 8 Yu Watanabe 2016-04-22 03:45:10 EDT
Thanks. Now less can be installed without man-db, and it works for me.
Comment 9 Jozef Mlich 2016-04-22 04:54:28 EDT
Patch looks good for me. Thanks Pavel.
Comment 10 Fedora Update System 2016-04-25 01:06:58 EDT
less-481-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9a937faae1
Comment 11 Fedora Update System 2016-04-25 02:07:25 EDT
less-481-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff70f6b6a3
Comment 12 Fedora Update System 2016-04-25 13:51:05 EDT
less-481-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9a937faae1
Comment 13 Fedora Update System 2016-04-25 20:52:48 EDT
less-481-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff70f6b6a3
Comment 14 Fedora Update System 2016-04-26 16:53:16 EDT
less-481-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2016-05-07 07:55:33 EDT
less-481-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.