Bug 1278858 - "lsusb -v" disconnects all USB devices
"lsusb -v" disconnects all USB devices
Status: CLOSED DUPLICATE of bug 1123805
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
ppc64le Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 10:03 EST by Laurent Vivier
Modified: 2015-11-09 03:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 03:23:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurent Vivier 2015-11-06 10:03:42 EST
Description of problem:

When we run "lsusb -v", all USB devices are disconnected and reconnected.
It happens with non privileged user (no need to be root).

Version-Release number of selected component (if applicable):

kernel-3.10.0-327.el7.ppc64le
qemu-kvm-rhev-2.3.0-31.el7
usbutils-007-5.el7.ppc64le
libusbx-1.0.15-4.el7.ppc64le

How reproducible:

100%

Steps to Reproduce:
1. lsusb -v
2. dmesg

[11572.406083] usb 1-1: USB disconnect, device number 5
[11572.585131] usb 1-1: new full-speed USB device number 7 using ohci-pci
[11572.808289] usb 1-1: New USB device found, idVendor=0627, idProduct=0001
[11572.808384] usb 1-1: New USB device strings: Mfr=1, Product=4, SerialNumber=5
[11572.808476] usb 1-1: Product: QEMU USB Keyboard
[11572.808560] usb 1-1: Manufacturer: QEMU
[11572.808643] usb 1-1: SerialNumber: 42
[11572.818916] input: QEMU QEMU USB Keyboard as /devices/pci0000:00/0000:00:01.0/usb1/1-1/1-1:1.0/input/input5
[11572.875217] hid-generic 0003:0627:0001.0006: input,hidraw0: USB HID v1.11 Keyboard [QEMU QEMU USB Keyboard] on usb-0000:00:01.0-1/input0
[11572.876383] usb 1-2: USB disconnect, device number 6
[11573.075116] usb 1-2: new full-speed USB device number 8 using ohci-pci
[11573.297530] usb 1-2: New USB device found, idVendor=0627, idProduct=0001
[11573.297624] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[11573.297716] usb 1-2: Product: QEMU USB Mouse
[11573.297800] usb 1-2: Manufacturer: QEMU
[11573.297882] usb 1-2: SerialNumber: 42
[11573.308010] input: QEMU QEMU USB Mouse as /devices/pci0000:00/0000:00:01.0/usb1/1-2/1-2:1.0/input/input6
[11573.308272] hid-generic 0003:0627:0001.0007: input,hidraw1: USB HID v0.01 Mouse [QEMU QEMU USB Mouse] on usb-0000:00:01.0-2/input0

Actual results:

The devices are disconnected and reconnected

Expected results:

The devices should not be disconnected.

Additional info:

/usr/libexec/qemu-kvm -name laurent-1 -machine pseries,accel=kvm -m 2048 -realtime mlock=off -smp 2,sockets=1,cores=1,threads=2 -chardev stdio,id=conmon,mux=on,signal=off -mon conmon -device spapr-vty,chardev=conmon -nodefaults -rtc base=localtime,clock=host -boot strict=on -device spapr-vscsi,id=scsi0,reg=0x2000 -drive file=/var/lib/libvirt/images/laurent-rhel7.2-le.qcow2,if=none,id=drive-scsi0-0-0-0,format=qcow2,cache=none,snapshot=on -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 -msg timestamp=on -nographic -netdev bridge,id=hostnet0,br=virbr0 -device spapr-vlan,id=net0,netdev=hostnet0,mac=52:54:00:22:ab:31, -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3 -usb -vga std -vnc :11
Comment 2 Xujun Ma 2015-11-08 23:41:46 EST
Reproduced the issue on latest version:

Version-Release number of selected component (if applicable):
Guest kernel: 3.10.0-324.e17.pp64le
qemu-kvm-rhev:2.3.0-31
libusbx-1.0.15-4.el7.ppc64le
usbutils-007-5.el7.ppc64le


Steps to Reproduce:
1. start a guest with command:
/usr/libexec/qemu-kvm \
 -m 16G -smp 16 -monitor stdio -qmp tcp::8889,server,nowait  -vnc :26\
 -usbdevice tablet \
 -boot menu=on \
 -rtc base=utc,clock=vm \
 -netdev tap,id=tap0,script=/etc/qemu-ifup \
 -device virtio-net-pci,netdev=tap0,bootindex=3,id=net0,mac=24:be:05:11:92:11 \
 -drive file=../img/sys72151015.qcow2,if=none,id=drive-0-0-0,format=qcow2,cache=none \
 -device virtio-blk-pci,drive=drive-0-0-0,bootindex=0,id=scsi0-0-0-0  \
 -device nec-usb-xhci,id=usbctr \
 -device ich9-usb-ehci1,id=usbctr2 \
 -device ich9-usb-ehci2,id=usbctr3 \
 -device usb-ehci,id=usbctr4 \
 -device pci-ohci,id=usbctr1,masterbus=usbctr2.0 \
 -drive file=../img/usb.qcow2,id=usbs1,if=none \
 -device usb-storage,id=storager1,serial,removable=off,drive=usbs1,bootindex=15\
 -drive file=../img/usb1.qcow2,id=usbs2,if=none \
 -device usb-storage,id=storager2,serial,removable=off,drive=usbs2,bootindex=2 \
 -device virtio-scsi-pci\
 -device scsi-cd,id=scsi-cd1,drive=scsi-cd1-dr,bootindex=1 \
 -drive file=../iso/RHEL-7.2-20151015.0-Server-ppc64le-dvd1.iso,if=none,id=scsi-cd1-dr,readonly=on,format=raw,cache=none \

2. display dmesg info with command "dmesg -w“
#dmesg -w

3. input “lsusb -v” by root user or non privileged user:
#lsusb -v

4. check output of dmesg 

Results:it displays info as follows:
[ 3702.202088] usb 7-1: USB disconnect, device number 39
[ 3702.801922] usb 7-1: new full-speed USB device number 46 using ohci-pci
[ 3703.014070] usb 7-1: not running at top speed; connect to a high speed hub
[ 3703.026264] usb 7-1: New USB device found, idVendor=0627, idProduct=0001
[ 3703.026266] usb 7-1: New USB device strings: Mfr=1, Product=4, SerialNumber=5
[ 3703.026268] usb 7-1: Product: QEMU USB Keyboard
[ 3703.026269] usb 7-1: Manufacturer: QEMU
[ 3703.026271] usb 7-1: SerialNumber: 42
[ 3703.036610] input: QEMU QEMU USB Keyboard as /devices/pci0000:00/0000:00:01.0/usb7/7-1/7-1:1.0/input/input30
[ 3703.092104] hid-generic 0003:0627:0001.001F: input,hidraw0: USB HID v1.11 Keyboard [QEMU QEMU USB Keyboard] on usb-0000:00:01.0-1/input0
[ 3703.092155] usb 7-2: USB disconnect, device number 43
[ 3703.411913] usb 7-2: new full-speed USB device number 47 using ohci-pci
[ 3703.624568] usb 7-2: not running at top speed; connect to a high speed hub
[ 3703.636767] usb 7-2: New USB device found, idVendor=0627, idProduct=0001
[ 3703.636769] usb 7-2: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[ 3703.636771] usb 7-2: Product: QEMU USB Mouse
[ 3703.636772] usb 7-2: Manufacturer: QEMU
[ 3703.636774] usb 7-2: SerialNumber: 42
[ 3703.647022] input: QEMU QEMU USB Mouse as /devices/pci0000:00/0000:00:01.0/usb7/7-2/7-2:1.0/input/input31
[ 3703.647252] hid-generic 0003:0627:0001.0020: input,hidraw2: USB HID v0.01 Mouse [QEMU QEMU USB Mouse] on usb-0000:00:01.0-2/input0
[ 3703.647309] usb 7-3: USB disconnect, device number 44
[ 3703.647311] usb 7-3.1: USB disconnect, device number 45
[ 3703.931920] usb 7-3: new full-speed USB device number 48 using ohci-pci
[ 3704.154495] usb 7-3: New USB device found, idVendor=0409, idProduct=55aa
[ 3704.154497] usb 7-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3704.154499] usb 7-3: Product: QEMU USB Hub
[ 3704.154500] usb 7-3: Manufacturer: QEMU
[ 3704.154502] usb 7-3: SerialNumber: 314159-pci@800000020000000:01.0-3
[ 3704.156554] hub 7-3:1.0: USB hub found
[ 3704.158555] hub 7-3:1.0: 8 ports detected
[ 3704.462513] usb 7-3.1: new full-speed USB device number 49 using ohci-pci
[ 3704.574594] usb 7-3.1: not running at top speed; connect to a high speed hub
[ 3704.586793] usb 7-3.1: New USB device found, idVendor=0627, idProduct=0001
[ 3704.586795] usb 7-3.1: New USB device strings: Mfr=1, Product=3, SerialNumber=5
[ 3704.586797] usb 7-3.1: Product: QEMU USB Tablet
[ 3704.586798] usb 7-3.1: Manufacturer: QEMU
[ 3704.586800] usb 7-3.1: SerialNumber: 42
[ 3704.599032] input: QEMU QEMU USB Tablet as /devices/pci0000:00/0000:00:01.0/usb7/7-3/7-3.1/7-3.1:1.0/input/input32
[ 3704.599249] hid-generic 0003:0627:0001.0021: input,hidraw1: USB HID v0.01 Pointer [QEMU QEMU USB Tablet] on usb-0000:00:01.0-3.1/input0
Comment 3 Laurent Vivier 2015-11-09 03:23:25 EST

*** This bug has been marked as a duplicate of bug 1123805 ***

Note You need to log in before you can comment on or make changes to this bug.