Bug 1278863 - Failed to install openshift-v3.0.1.0 using atomic-openshift-utils
Failed to install openshift-v3.0.1.0 using atomic-openshift-utils
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 10:16 EST by Anping Li
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 10:42:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anping Li 2015-11-06 10:16:39 EST
Description of problem:

Once installed openshift-3.0.1.0 mannuly.  The ose v3.0.2.0 can be installed successfully.

it seem the openshift_pkg_version wasn't appled to the base package

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.0.7-1.git.48.75d357c.el7aos.noarch

How reproducible:
always

Steps to Reproduce:
1. yum install atomic-openshift-utils
2. create ansible inventory file and set openshift_pkg_version=-3.0.1.0 in inventory file
3.  ansible-playbook -i config/host2  /usr/share/ansible/openshift-ansible/playbooks/byo/config.yml

TASK: [openshift_master | Install Master package] ***************************** 
failed:  [10.3.8.193] => {"changed": true, "rc": 1, "results": ["Resolving  Dependencies\n--> Running transaction check\n---> Package  openshift-master.x86_64 0:3.0.1.0-1.git.529.dcab62c.el7ose will be  installed\n--> Processing Dependency: openshift =  3.0.1.0-1.git.529.dcab62c.el7ose for package:  openshift-master-3.0.1.0-1.git.529.dcab62c.el7ose.x86_64\n-->  Finished Dependency Resolution\n You could try using --skip-broken to  work around the problem\n You could try running: rpm -Va --nofiles  --nodigest\n"]}
msg: Error: Package: openshift-master-3.0.1.0-1.git.529.dcab62c.el7ose.x86_64 (rhel-7-server-ose-3.0-rpms)
           Requires: openshift = 3.0.1.0-1.git.529.dcab62c.el7ose
           Installed: openshift-3.0.2.0-0.git.20.656dc3e.el7ose.x86_64 (@rhel-7-server-ose-3.0-rpms)
               openshift = 3.0.2.0-0.git.20.656dc3e.el7ose
           Available: openshift-3.0.0.0-0.git.25.235b0e7.el7ose.x86_64 (rhel-7-server-ose-3.0-rpms)
               openshift = 3.0.0.0-0.git.25.235b0e7.el7ose
           Available: openshift-3.0.0.1-1.git.4.eab4c86.el7ose.x86_64 (rhel-7-server-ose-3.0-rpms)
               openshift = 3.0.0.1-1.git.4.eab4c86.el7ose
           Available: openshift-3.0.1.0-1.git.525.eddc479.el7ose.x86_64 (rhel-7-server-ose-3.0-rpms)
               openshift = 3.0.1.0-1.git.525.eddc479.el7ose
           Available: openshift-3.0.1.0-1.git.527.f8d5fed.el7ose.x86_64 (rhel-7-server-ose-3.0-rpms)
               openshift = 3.0.1.0-1.git.527.f8d5fed.el7ose
           Available: openshift-3.0.1.0-1.git.529.dcab62c.el7ose.x86_64 (rhel-7-server-ose-3.0-rpms)
               openshift = 3.0.1.0-1.git.529.dcab62c.el7ose
           Available: openshift-3.0.2.0-0.git.5.ee06ab6.el7ose.x86_64 (rhel-7-server-ose-3.0-rpms)
               openshift = 3.0.2.0-0.git.5.ee06ab6.el7ose
           Available: openshift-3.0.2.0-0.git.16.4d626fe.el7ose.x86_64 (rhel-7-server-ose-3.0-rpms)
               openshift = 3.0.2.0-0.git.16.4d626fe.el7ose


Expected Result:

installation should be succeed.


Additional info:
Once installed openshift-3.0.1.0 mannuly.  The ose v3.0.1.0 can be installed successfully.

After installation,  two issues were found:
1.  docker 1.8.2 is installed, which isn't comiable with ose v3.0.1.0
2.  since ose v3.0.1.0 is using docker-registry-v1  --insecure-registry  172.30.0.0/24' should be added.
Comment 2 Jason DeTiberus 2015-11-06 16:19:24 EST
We were installing the openshift package in the openshift_master_ca role without appending the requested version.

Addressed in this PR: https://github.com/openshift/openshift-ansible/pull/837
Comment 3 Anping Li 2015-11-09 03:18:51 EST
Verfied and pass on atomic-openshift-utils-3.0.7-1.git.131.21caa21.el7aos.noarch

Note You need to log in before you can comment on or make changes to this bug.