Bug 127887 - installer is unfriendly to non-DDC monitor
installer is unfriendly to non-DDC monitor
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
: 114796 121827 130679 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-14 17:47 EDT by John Reiser
Modified: 2008-05-09 13:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 04:13:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2004-07-14 17:47:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
A Sony Multiscan 15sf CRT monitor will do 1024x768 @75Hz, but it has
no DDC.  During install and firstboot, the monitor is detected as
"Unprobed monitor" and there is no opportunity to override this, nor
is there a message about how to change it after installation.  The
screen comes up as 800x600 instead.

Not allowing override of "Unprobed monitor" during install and/or
firstboot is an unexpected decrease in functionality.  Both the
Anaconda developers and I have worked hard over the past 2 or 3 years
to get the manual choice working correctly (H&V frequencies were
swapped once; Dell Laptop screen choice was not clear; etc.).  The FC1
and FC2 installers finally had good support for non-DDC monitors.  Why
was this support removed?



Version-Release number of selected component (if applicable):
firstboot-1.3.16-1

How reproducible:
Always

Steps to Reproduce:
1. Fresh graphical install from CD-ROM using CRT monitor without DDC.
2. Enter X11 configuration screen of firstboot.
3.
    

Actual Results:  During firstboot the only choice is color depth
(hundreds, thousands, or millions of colors); there is no choice to
override "Unprobed monitor".

Expected Results:  There should be a choice to override "Unprobed
monitor" by choosing from the monitor database.

Additional info:
Comment 1 Barry K. Nathan 2004-07-14 23:53:41 EDT
If you boot the installer with the "resolution=1024x768" option and
(re)install with that, does that make any difference to the final
installed system?
Comment 2 Jeremy Katz 2004-07-15 01:06:09 EDT
The plan is to add a "select monitor" button to the firstboot screen,
just haven't gotten there yet.
Comment 3 John Reiser 2004-07-15 01:54:38 EDT
Replying to Comment #1 (Barry K Nathan): booting the installer with
"linux resolution=1024x768" gets a Monitor section in
/etc/X11/xorg.conf with HorizSync of 31.5 - 48.5, and a Screen section
than has 1024x768 first.  Thus the screen is 1024x768 @60Hz, according
to "xrandr".  In order to get @75Hz, then I copy from RHEL3 which has
HorizSync 31.0 - 64.0 (and VertRefresh of 50.0 to 120.0 instead of
40.0 - 70.0).
Comment 4 Paul Nasrat 2004-07-15 02:30:09 EDT
In addition to the feature work one useful thing the original poster 
can do to get the monitor added to the database is (quoting mharris):

" All you have to do, is attach Microsoft Windows .INF 
files supplied by the monitor manufacturer into a bugzilla bug 
report that requests the entries be added to the database.  Feel 
free to attach all .INF files for all monitors of a given brand, 
or of as many brands as you like, and they'll all get processed 
simultaneously."

If you could open a seperate bug against hwdata with the monitor.inf
attached that would be useful.
Comment 5 Barry K. Nathan 2004-07-15 04:22:40 EDT
Sony Multiscan 15sf is already in the database -- it just doesn't have
DDC support and thus can't be automatically probed.
Comment 6 Paul Nasrat 2004-08-19 05:37:42 EDT
I've added a button to the firstboot screen in system-config-display
for monitor detection. Will appear in rawhide shortly.
Comment 7 Paul Nasrat 2004-08-19 06:24:34 EDT
*** Bug 121827 has been marked as a duplicate of this bug. ***
Comment 8 Paul Nasrat 2004-08-24 04:54:34 EDT
*** Bug 130679 has been marked as a duplicate of this bug. ***
Comment 9 Paul Nasrat 2004-08-24 04:58:56 EDT
*** Bug 114796 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.