This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1278886 - Remove hard dependencies on vino and rygel
Remove hard dependencies on vino and rygel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
24
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 11:27 EST by Robert Marcano
Modified: 2016-09-27 11:19 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-27 11:19:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Marcano 2015-11-06 11:27:51 EST
control-center has a hard dependency on vino and rygel. When setting up a controlled desktop (no internet, no removable media, only required applications installed) based on GNOME, there is no way to remove the capability of users of sharing desktop or media on the network because these these packages are required by control-center.

Previous versions of GNOME control center had plugins, It is now a monolithic binary with all functionality, IIRC for performance reasons, but it still should be able to detect those packages are not installed and simply disable those settings pages telling the user the required packages are not installed, maybe pointing to GNOME Software for installation
Comment 1 Bastien Nocera 2016-09-22 19:00:32 EDT
Which would save you a couple of kilobytes on disk. We're not interested in providing a bag of bits, with separate optional packages for every single little bit of functionality.

You're more than welcome rebuilding the control-center package without those dependencies, but we won't do that in Fedora.
Comment 2 Sylvain Petreolle 2016-09-23 06:47:30 EDT
Robert is not looking for a few kilobytes of disk space.
Unwanted capabilities should not be installed at all.
Sharing media and desktop involves security concerns.
Comment 3 Bastien Nocera 2016-09-23 07:02:18 EDT
(In reply to Sylvain Petreolle from comment #2)
> Robert is not looking for a few kilobytes of disk space.
> Unwanted capabilities should not be installed at all.
> Sharing media and desktop involves security concerns.

Then please file bugs, upstream, against gsettings-desktop-schemas to add the necessary lockdown to stop those features being available to users.

Existing lockdown settings:
https://git.gnome.org/browse/gsettings-desktop-schemas/tree/schemas/org.gnome.desktop.lockdown.gschema.xml.in
Comment 4 Robert Marcano 2016-09-23 08:32:26 EDT
(In reply to Bastien Nocera from comment #3)
> (In reply to Sylvain Petreolle from comment #2)
> > Robert is not looking for a few kilobytes of disk space.
> > Unwanted capabilities should not be installed at all.
> > Sharing media and desktop involves security concerns.
> 
> Then please file bugs, upstream, against gsettings-desktop-schemas to add
> the necessary lockdown to stop those features being available to users.
> 
> Existing lockdown settings:
> https://git.gnome.org/browse/gsettings-desktop-schemas/tree/schemas/org.
> gnome.desktop.lockdown.gschema.xml.in

Current lockdown settings are only an UI thing. People can still start for example Rygel from the CLI. I am only asking for a soft dependency. If the Rygel  is not installed say it and not enable the panel. Will file upstream bug.
Comment 5 Robert Marcano 2016-09-23 08:41:14 EDT
Now that I test again. I don't see why an upstream bug is needed if I force remove rygel

# rpm -e rygel --nodeps

gnome-control-center is doing the right thing, not showing the media sharing option. The problem is the hard RPM dependency. Please reconsider reopening the bug.

The same happen with vino.
Comment 6 Bastien Nocera 2016-09-27 11:19:38 EDT
Still WONTFIX, sorry.

Note You need to log in before you can comment on or make changes to this bug.