Bug 1278985 - Fedora should be compiled with CONFIG_CMA=y to enable Contiguous Memory Allocator
Fedora should be compiled with CONFIG_CMA=y to enable Contiguous Memory Alloc...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 18:05 EST by hkimura
Modified: 2016-03-22 18:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-22 18:00:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hkimura 2015-11-06 18:05:41 EST
Description of problem:
Both Fedora 23 Workstation and Server do not enable CMA (Contiguous Memory Allocator), which is required for a few new features, such as 1GB hugepage allocation/deallocation at _runtime_: https://lwn.net/Articles/594435/

RHEL 7.1 and later already enabled this, so why not.
This will benefit various big-memory applications and DMA applications that use CMA.

To enable CMA, please add "CONFIG_CMA=y" to .config for kernel compilation.

Version-Release number of selected component (if applicable):
FC23 (Kernel 4.2.5 as of today)

How reproducible:
Always

Steps to Reproduce:
1. (to check the current config) grep CONFIG_CMA /boot/config*
2.
3.

Actual results:
Just says: "# CONFIG_CMA is not set"

Expected results:
Has the line: "CONFIG_CMA=y"



Additional info:
Ubuntu enabled it long ago (at least in UB1404) probably for DMA applications. RHEL did it too since 7.1 and onwards.
Comment 1 Laura Abbott 2015-11-10 12:40:19 EST
I'll turn this on in rawhide for x86_64. CMA is mostly stable now but it's a big enough change that turning it on in stable releases really calls for more testing.
Comment 2 hkimura 2015-11-11 17:01:12 EST
Thanks, I'll try rawhide when you push the change.
Comment 3 Peter Robinson 2015-11-12 06:25:40 EST
(In reply to Laura Abbott from comment #1)
> I'll turn this on in rawhide for x86_64. CMA is mostly stable now but it's a
> big enough change that turning it on in stable releases really calls for
> more testing.

Just as a data point we've had it enabled in ARMv7 for some time as it was needed there for some display support.
Comment 4 Peter Robinson 2016-03-22 18:00:12 EDT
In at least Fedora 23 in 4.4+

Note You need to log in before you can comment on or make changes to this bug.