Bug 1278993 - configured proxy ignored under certain circumstances
configured proxy ignored under certain circumstances
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 18:50 EST by Yevgeniy
Modified: 2015-12-02 16:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 16:09:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yevgeniy 2015-11-06 18:50:04 EST
Description of problem:
when installing Fedora 23 from a Live-CD the installer ignores the proxy configuration under described circumstances.

Steps to Reproduce:
1. start installation routine from Fedora-Server-netinst-x86_64-23.iso
2. open the "Installation Source" dialog
3. choose "Proxy setup..." and configure a proxy
4. Do not change anything else
5. Hit "Done" and check access.log of your proxy while installation routine downloads the metadata. Nothing happens in access.log
6. open the "Installation Source" dialog again
7. switch from "closest mirror" to "http://"
8. type in random url. Does not have to be a real mirror
9. hit "Done". Wait until "Installation Source" is available again
10. open the "Installation Source" dialog again
11. switch back from "http://" to "closest mirror"
12. hit "Done" and check access.log of your proxy again. Now you see the installation routine accessing files from a mirror

Actual Result:
it looks like the installation routine does not hand over the proxy settings to dnf if you do not specify a mirror-url. Once you did, you can choose "closest mirror" again.
Comment 1 David Shea 2015-12-02 16:09:57 EST
The reason a proxy server is not used at step 5 is because the repo metadata has already been fetched without a proxy, since anaconda uses "Closest Mirror" by default and will automatically fetch the repository metadata if able. The proxy is not used because at that point there is nothing more to fetch.

In order to use a proxy for the Closest Mirror metadata, you can either specify a proxy during boot by adding inst.proxy=<proxy-url> on the boot command line, or you can add inst.askmethod to the boot command line to disable the automatic repo configuration.

Note You need to log in before you can comment on or make changes to this bug.