Bug 1279212 - pius: No module named libpius
pius: No module named libpius
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pius (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Praveen Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 11:04 EST by Jan Včelák
Modified: 2016-03-27 07:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-27 07:59:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Včelák 2015-11-08 11:04:24 EST
Description of problem:

Pius cannot be started, the package seems to be incomplete.

$ rpm -ql pius
/usr/bin/pius
/usr/bin/pius-keyring-mgr
/usr/bin/pius-party-worksheet
/usr/share/doc/pius
/usr/share/doc/pius/COPYING
/usr/share/doc/pius/README
/usr/share/doc/pius/README.keyring-mgr
/usr/share/doc/pius/pius.spec

Version-Release number of selected component (if applicable):
pius-2.1.1-2.fc23.noarch

How reproducible:
always


Steps to Reproduce:
1. start pius
2.
3.

Actual results:

$ pius
Traceback (most recent call last):
  File "/bin/pius", line 22, in <module>
    from libpius import signer as psigner
ImportError: No module named libpius


Expected results:


Additional info:
Comment 1 Praveen Kumar 2015-11-09 23:37:49 EST
Thanks for bug report, will work on this coming weekend and update this package.
Comment 2 Amit Shah 2015-12-27 10:09:59 EST
As a workaround, the 2.2.0 build at http://koji.fedoraproject.org/koji/buildinfo?buildID=689635 works fine.
Comment 3 Praveen Kumar 2015-12-28 00:18:41 EST
This is pushed to stable repo (f22 and f23) sorry for delay.

Note You need to log in before you can comment on or make changes to this bug.