Bug 1279220 - [abrt] shotwell: object_heap_destroy(): shotwell killed by SIGFPE
[abrt] shotwell: object_heap_destroy(): shotwell killed by SIGFPE
Status: CLOSED DUPLICATE of bug 1286365
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:9cd3939e2235ca8662d78e27f16...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 12:06 EST by code
Modified: 2015-11-28 11:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-28 11:09:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (124.02 KB, text/plain)
2015-11-08 12:06 EST, code
no flags Details
File: cgroup (190 bytes, text/plain)
2015-11-08 12:06 EST, code
no flags Details
File: core_backtrace (74.26 KB, text/plain)
2015-11-08 12:06 EST, code
no flags Details
File: dso_list (19.55 KB, text/plain)
2015-11-08 12:07 EST, code
no flags Details
File: environ (1.92 KB, text/plain)
2015-11-08 12:07 EST, code
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-08 12:07 EST, code
no flags Details
File: maps (96.87 KB, text/plain)
2015-11-08 12:07 EST, code
no flags Details
File: mountinfo (4.02 KB, text/plain)
2015-11-08 12:07 EST, code
no flags Details
File: open_fds (118.50 KB, text/plain)
2015-11-08 12:07 EST, code
no flags Details
File: proc_pid_status (1014 bytes, text/plain)
2015-11-08 12:07 EST, code
no flags Details
File: var_log_messages (739 bytes, text/plain)
2015-11-08 12:07 EST, code
no flags Details
Video file that seems to cause the crash (11.83 MB, application/octet-stream)
2015-11-08 13:01 EST, code
no flags Details

  None (edit)
Description code 2015-11-08 12:06:51 EST
Description of problem:
Shotwell crashes on launch.

Version-Release number of selected component:
shotwell-0.22.0-5.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        shotwell
crash_function: object_heap_destroy
executable:     /usr/bin/shotwell
global_pid:     28570
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (8 frames)
 #0 object_heap_destroy at object_heap.c:275
 #1 destroy_heap at vdpau_driver.c:138
 #2 vdpau_common_Terminate at vdpau_driver.c:126
 #4 vdpau_Terminate_Current at vdpau_driver_template.h:537
 #5 __vaDriverInit_0_38 at vdpau_driver_template.h:563
 #7 va_openDriver at va.c:296
 #8 vaInitialize at va.c:559
 #9 gst_vaapi_display_new at gstvaapidisplay.c:937
Comment 1 code 2015-11-08 12:06:56 EST
Created attachment 1091320 [details]
File: backtrace
Comment 2 code 2015-11-08 12:06:57 EST
Created attachment 1091321 [details]
File: cgroup
Comment 3 code 2015-11-08 12:06:59 EST
Created attachment 1091322 [details]
File: core_backtrace
Comment 4 code 2015-11-08 12:07:00 EST
Created attachment 1091323 [details]
File: dso_list
Comment 5 code 2015-11-08 12:07:01 EST
Created attachment 1091324 [details]
File: environ
Comment 6 code 2015-11-08 12:07:02 EST
Created attachment 1091325 [details]
File: limits
Comment 7 code 2015-11-08 12:07:03 EST
Created attachment 1091326 [details]
File: maps
Comment 8 code 2015-11-08 12:07:04 EST
Created attachment 1091327 [details]
File: mountinfo
Comment 9 code 2015-11-08 12:07:06 EST
Created attachment 1091328 [details]
File: open_fds
Comment 10 code 2015-11-08 12:07:06 EST
Created attachment 1091329 [details]
File: proc_pid_status
Comment 11 code 2015-11-08 12:07:07 EST
Created attachment 1091330 [details]
File: var_log_messages
Comment 12 code 2015-11-08 12:56:29 EST
This appears to be triggered by a particular video file. The underlying bug is probably in Totem or gstreamer or something; the same file crashes Totem when opened there (#1277242). I don’t know enough about the relevant libraries to know exactly which component this should really be filed against. The video plays fine in mplayer.
Comment 13 code 2015-11-08 13:01 EST
Created attachment 1091332 [details]
Video file that seems to cause the crash
Comment 14 code 2015-11-08 13:12:12 EST
It’s not just the one video file. Many others cause a similar crash.
Comment 15 code 2015-11-28 10:50:19 EST
See also #1278434
Comment 16 code 2015-11-28 10:53:57 EST
Note that this doesn’t just prevent viewing the affected video files in Shotwell; it actually makes Shotwell completely useless when affected video files are anywhere in the library.
Comment 17 code 2015-11-28 11:09:10 EST

*** This bug has been marked as a duplicate of bug 1286365 ***

Note You need to log in before you can comment on or make changes to this bug.