Bug 1279259 - Clementine should depend on gstreamer-plugins-good
Clementine should depend on gstreamer-plugins-good
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clementine (Show other bugs)
23
All All
unspecified Severity medium
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 17:31 EST by Christoph Erhardt
Modified: 2016-01-04 14:57 EST (History)
2 users (show)

See Also:
Fixed In Version: clementine-1.2.3-14.fc23 clementine-1.2.3-14.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 13:52:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.spec-file patch (336 bytes, patch)
2015-12-01 04:54 EST, Christoph Erhardt
no flags Details | Diff
.spec-file patch (348 bytes, patch)
2015-12-01 04:56 EST, Christoph Erhardt
no flags Details | Diff

  None (edit)
Description Christoph Erhardt 2015-11-08 17:31:06 EST
The Clementine package automatically pulls in gstreamer and gstreamer-plugins-base, but to play any audio files at all, it additionally requires gstreamer-plugins-good to be installed. This is because Clementine uses autoaudiosink as its default audio sink, which is is part of GStreamer's "good" plugin set (see http://gstreamer.freedesktop.org/documentation/plugins.html).

Without gstreamer-plugins-good installed, Clementine will show the following error message whenever the user tries to play any file:
"GStreamer could not create the element: autoaudiosink.
Please make sure that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)"

This means that Clementine is useless without gstreamer-plugins-good, which is why it should have a hard dependency on it.
Comment 1 Christoph Erhardt 2015-12-01 04:54 EST
Created attachment 1100808 [details]
.spec-file patch

Here's a patch for the .spec file.
Comment 2 Christoph Erhardt 2015-12-01 04:56 EST
Created attachment 1100809 [details]
.spec-file patch
Comment 3 Fedora Update System 2015-12-01 10:07:02 EST
clementine-1.2.3-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0b0c0bc801
Comment 4 Fedora Update System 2015-12-01 17:30:09 EST
clementine-1.2.3-14.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update clementine'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0b0c0bc801
Comment 5 Fedora Update System 2015-12-03 11:03:15 EST
clementine-1.2.3-14.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update clementine'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-a0f431676b
Comment 6 Fedora Update System 2016-01-04 13:52:47 EST
clementine-1.2.3-14.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2016-01-04 14:57:24 EST
clementine-1.2.3-14.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.