Bug 1279273 - About compression option for qcow2
About compression option for qcow2
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 20:00 EST by kwsk
Modified: 2015-11-10 21:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 08:41:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kwsk 2015-11-08 20:00:03 EST
Description of problem:

It is not a bug but a request

It would be possible to compress in creating qcow2 image
(qemu-img convert -c option)

But, there was not option like that in virt-v2v
Could you add compression option

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Pino Toscano 2015-11-09 12:00:13 EST
You are using -o local for virt-v2v, I guess?
Comment 2 kwsk 2015-11-09 20:13:37 EST
Yes I'm using -o local -of qcow2
Comment 3 kwsk 2015-11-09 20:46:34 EST
And editing v2v.ml directly now
Comment 4 Richard W.M. Jones 2015-11-10 03:41:59 EST
It seems reasonable to have a --qcow2-compression option
or something like that.  It would just add the -c option
to the qemu-img convert command.

It seems as if it would work with all output modes too,
although it is possible that -o glance and -o rhev do a
reconversion step (not in v2v).
Comment 5 Richard W.M. Jones 2015-11-10 04:00:59 EST
Patch posted:
https://www.redhat.com/archives/libguestfs/2015-November/msg00103.html
Comment 6 Richard W.M. Jones 2015-11-10 08:41:15 EST
Upstream in commit 6d46eb33bffbd48c75539cca59c554d184cb5c05
libguestfs >= 1.31.26
Comment 7 kwsk 2015-11-10 21:49:05 EST
Thank you for commit

Note You need to log in before you can comment on or make changes to this bug.