Bug 1279276 - Gnome-Software fails to install any software
Gnome-Software fails to install any software
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 20:33 EST by Ariel
Modified: 2016-01-08 12:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 12:39:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ariel 2015-11-08 20:33:12 EST
Description of problem:

Gnome-Software fails to install any software - it shows an error message instead of installing.

DNF can install software with no issues.

This is on a recently-upgraded Fedora 23 (upgraded from Fedora 22, where gnome-software was working fine)

I saw some similar reports in "Ask Fedora". 

Log below. I noticed in the log output that gnome-software seems to be trying to install Fedora 22 packages instead of F23. 


Version-Release number of selected component (if applicable):


How reproducible:
Every time


Steps to Reproduce:
1.Select any non-installed software in Gnome-Software
2.Click Install
3.Window pops up saying "Sorry, this didn't work" 

Actual results:
Error message pops up, and some errors show in Journal (see below)


Expected results:
app should be installed


Additional info:

Output of journalctl -r (note the inverted order)

Nov 08 20:26:45 rew-localdomain gnome-session[2199]: (org.gnome.Software:2647): Gs-WARNING **: failed to install org.gnome.Polari.desktop: Failed to find polari;3.16.1-1.fc22;x86_64;fedora
Nov 08 20:26:45 rew-localdomain PackageKit[1677]: install-packages transaction /3819_ededcead from uid 1000 finished with failed after 34ms
Nov 08 20:26:45 rew-localdomain PackageKit[1677]: uid 1000 obtained auth for org.freedesktop.packagekit.package-install
Nov 08 20:26:45 rew-localdomain PackageKit[1677]: new install-packages transaction /3819_ededcead scheduled from uid 1000
Nov 08 20:26:45 rew-localdomain PackageKit[1677]: uid 1000 is trying to obtain org.freedesktop.packagekit.package-install auth (only_trusted:1)
Nov 08 20:26:43 rew-localdomain PackageKit[1677]: resolve transaction /3818_eebaabda from uid 1000 finished with success after 17ms
Comment 1 Richard Hughes 2016-01-08 05:21:24 EST
What's the console message if you do:

killall gnome-software
gnome-software --verbose

and then try to install an application? Thanks.
Comment 2 Ariel 2016-01-08 12:39:21 EST
Now it works, with or without --verbose.  Can't reproduce the issue.
Not sure what changed in the interim.
Thanks for following up.

Note You need to log in before you can comment on or make changes to this bug.