Bug 1279302 - AttributeError: 'NoneType' object has no attribute 'query'
AttributeError: 'NoneType' object has no attribute 'query'
Status: CLOSED DUPLICATE of bug 1274957
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:622cbdfbb25a93f4e827e73b8d4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 00:39 EST by Joachim Frieben
Modified: 2015-11-09 09:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 09:59:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (384.59 KB, text/plain)
2015-11-09 00:39 EST, Joachim Frieben
no flags Details
File: anaconda.log (35.41 KB, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: dnf.log (2.22 KB, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: environ (459 bytes, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: lsblk_output (1.26 KB, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: nmcli_dev_list (1.20 KB, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: os_info (451 bytes, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: program.log (31.94 KB, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: storage.log (123.03 KB, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: syslog (69.21 KB, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: ifcfg.log (2.71 KB, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details
File: packaging.log (313 bytes, text/plain)
2015-11-09 00:40 EST, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2015-11-09 00:39:48 EST
Version-Release number of selected component:
anaconda-23.19.10-1

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 1200, in _add_comps_trans
    if not self.sack.query().filter(name=it):
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 1288, in group_install
    return self._add_comps_trans(trans)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 481, in _select_group
    self._base.group_install(grp, types, exclude=exclude)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 316, in _apply_selections
    self._select_group('core', required=True)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 589, in checkSoftwareSelection
    self._apply_selections()
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/software.py", line 216, in checkSoftwareSelection
    self.payload.checkSoftwareSelection()
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'NoneType' object has no attribute 'query'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-23-x86_64 quiet
dnf.rpm.log:    Nov 09 05:36:06 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Joachim Frieben 2015-11-09 00:39:58 EST
Created attachment 1091534 [details]
File: anaconda-tb
Comment 2 Joachim Frieben 2015-11-09 00:40:00 EST
Created attachment 1091535 [details]
File: anaconda.log
Comment 3 Joachim Frieben 2015-11-09 00:40:01 EST
Created attachment 1091536 [details]
File: dnf.log
Comment 4 Joachim Frieben 2015-11-09 00:40:02 EST
Created attachment 1091537 [details]
File: environ
Comment 5 Joachim Frieben 2015-11-09 00:40:04 EST
Created attachment 1091538 [details]
File: lsblk_output
Comment 6 Joachim Frieben 2015-11-09 00:40:05 EST
Created attachment 1091539 [details]
File: nmcli_dev_list
Comment 7 Joachim Frieben 2015-11-09 00:40:07 EST
Created attachment 1091540 [details]
File: os_info
Comment 8 Joachim Frieben 2015-11-09 00:40:08 EST
Created attachment 1091541 [details]
File: program.log
Comment 9 Joachim Frieben 2015-11-09 00:40:12 EST
Created attachment 1091542 [details]
File: storage.log
Comment 10 Joachim Frieben 2015-11-09 00:40:14 EST
Created attachment 1091543 [details]
File: syslog
Comment 11 Joachim Frieben 2015-11-09 00:40:15 EST
Created attachment 1091544 [details]
File: ifcfg.log
Comment 12 Joachim Frieben 2015-11-09 00:40:17 EST
Created attachment 1091545 [details]
File: packaging.log
Comment 13 David Shea 2015-11-09 09:59:37 EST
Looks like the same as 1274957, where the package sack is being reset unexpectedly.

*** This bug has been marked as a duplicate of bug 1274957 ***

Note You need to log in before you can comment on or make changes to this bug.