Bug 1279342 - Remove data center fails on an upgraded Data center with storage domains in maintenance mode
Remove data center fails on an upgraded Data center with storage domains in m...
Status: CLOSED DUPLICATE of bug 1272110
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Tal Nisan
Aharon Canan
storage
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 03:49 EST by Gilad Lazarovich
Modified: 2016-06-23 00:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 10:21:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
glazarov: planning_ack?
glazarov: devel_ack?
glazarov: testing_ack?


Attachments (Terms of Use)
engine and vdsm logs (1.46 MB, application/x-gzip)
2015-11-09 03:49 EST, Gilad Lazarovich
no flags Details

  None (edit)
Description Gilad Lazarovich 2015-11-09 03:49:50 EST
Created attachment 1091643 [details]
engine and vdsm logs

Description of problem:
Unable to remove Data center

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a Data center using version 3.4
2. Create a Cluster (using version 3.6)
3. Add a host and a pair of storage domains (I used NFS)
4. Create a VM with a disk in each of the storage domains
5. Upgrade the Data center to version 3.6
6. Wait until the OVF stores are created on both storage domains
7. Remove the VM and its disks
8. Place both storage domains in maintenance mode, the non-master storage domain should also be detached
9. When the Data center reaches maintenance mode, attempt to remove it

Actual results:
The remove Data center operation fails

Expected results:
The data center should be removed

Additional info:
Find attached engine and vdsm logs
Comment 1 Allon Mureinik 2015-11-09 05:00:15 EST
Tal, isn't this similar to a BZ you're already looking into?
Comment 2 Gilad Lazarovich 2015-11-09 07:41:33 EST
Looks like Raz filed a similar bug: https://bugzilla.redhat.com/show_bug.cgi?id=1272110
Comment 3 Allon Mureinik 2015-11-10 01:13:08 EST
Gilad, can you list the rpm versions for engine and vdsm you encountered this in please?
Comment 4 Gilad Lazarovich 2015-11-10 04:31:32 EST
Allon, here are the RPM versions:

Engine:
ovirt-engine-extension-aaa-jdbc-1.0.1-1.el6ev.noarch
ovirt-vmconsole-1.0.0-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.6.0.3-0.1.el6.noarch
ovirt-engine-extension-aaa-ldap-setup-1.1.0-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-common-3.6.0.3-0.1.el6.noarch
ovirt-host-deploy-1.4.0-1.el6ev.noarch
ovirt-engine-extension-aaa-ldap-1.1.0-1.el6ev.noarch
ovirt-host-deploy-java-1.4.0-1.el6ev.noarch
ovirt-engine-extension-aaa-misc-1.0.0-2.el6ev.noarch
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch

VDSM:
vdsm-infra-4.17.10.1-0.el7ev.noarch
vdsm-jsonrpc-4.17.10.1-0.el7ev.noarch
vdsm-python-4.17.10.1-0.el7ev.noarch
vdsm-yajsonrpc-4.17.10.1-0.el7ev.noarch
vdsm-4.17.10.1-0.el7ev.noarch
vdsm-cli-4.17.10.1-0.el7ev.noarch
vdsm-xmlrpc-4.17.10.1-0.el7ev.noarch
vdsm-hook-ethtool-options-4.17.10.1-0.el7ev.noarch
Comment 5 Tal Nisan 2015-11-10 10:21:01 EST
Indeed, same scenario at the bottom line, much longer way to reproduce, closing as duplicate

*** This bug has been marked as a duplicate of bug 1272110 ***

Note You need to log in before you can comment on or make changes to this bug.