Bug 1279384 - add crane logs in foreman-debug
add crane logs in foreman-debug
Status: CLOSED DEFERRED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Foreman Debug (Show other bugs)
6.1.3
x86_64 Linux
high Severity high (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
http://projects.theforeman.org/issues...
: EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 06:02 EST by Christophe Augello
Modified: 2017-03-14 13:17 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-14 13:17:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 15968 None None None 2016-08-03 16:02 EDT

  None (edit)
Description Christophe Augello 2015-11-09 06:02:17 EST
Description of problem:

add crane logs in foreman-debug

Version-Release number of selected component (if applicable):

sos-3.2-15

Actual results:

sos_commands/foreman/foreman-debug/var/log/httpd is missing crane logs.

Expected results:

crane logs included.

Additional info:
Comment 2 Pavel Moravec 2015-11-09 09:45:55 EST
Since these logs are expected to be collected by external command foreman-debug, changing product to Sat6.
Comment 4 Lukas Zapletal 2015-11-16 07:57:05 EST
Can you guys specify what filename pattern are we supposed to add?
Comment 5 Bryan Kearney 2016-01-12 13:42:52 EST
michael, can you please see comment 4.
Comment 6 Michael Hrivnak 2016-01-13 13:33:28 EST
Crane logs direct to stderr. Apache should be putting that output in its error log.
Comment 7 Lukas Zapletal 2016-02-15 04:54:32 EST
Michael, can you please give me an example of some logs that crane record? I can't grep a single message containing "crane" in a satellite6 system. Ideally with some simple action I need to perform to get such a log(s). Thanks!
Comment 8 Michael Hrivnak 2016-02-15 15:27:52 EST
When crane starts, it logs one of three messages about loading a config file. You can see them here:

https://github.com/pulp/crane/blob/1c5e817/crane/config.py#L60-L67
Comment 9 Lukas Zapletal 2016-02-16 11:01:57 EST
Chris, I've doublechecked and we currently add the following file pattern into foreman-debug:

add_files /var/log/{httpd,apache2}/*error_log*

We do not collect access_logs because these contain lot of entries but the error_log should be sufficient (should contain logs from all WSGI apps).

The crane component in Satellite 6 is configured with default apache logging setting:

https://github.com/Katello/puppet-crane/blob/master/manifests/apache.pp

Check the error_log once again, your messages should be there.
Comment 10 Christophe Augello 2016-04-14 07:32:53 EDT
perfect, thx Lukas
Comment 11 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 12 Bryan Kearney 2016-07-26 11:38:43 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 14 Zach Huntington-Meath 2016-08-03 15:20:14 EDT
Created redmine issue http://projects.theforeman.org/issues/15968 from this bug
Comment 15 Bryan Kearney 2016-08-04 04:09:45 EDT
Upstream bug component is Content Management
Comment 16 Bryan Kearney 2016-08-24 16:10:27 EDT
Upstream bug component is Infrastructure
Comment 17 Bryan Kearney 2016-10-22 12:10:41 EDT
Upstream bug assigned to lzap@redhat.com
Comment 18 Bryan Kearney 2017-03-14 13:17:37 EDT
An upstream issue has been opened for this. When this is fixed, the next version of satellite will contain the fix. We will no longer be tracking this downstream. If you feel this was closed in error, please feel free to re-open with additional information.

Note You need to log in before you can comment on or make changes to this bug.