This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1279412 - Test case failure: pkcon install broken dependencies
Test case failure: pkcon install broken dependencies
Status: NEW
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: PackageKit (Show other bugs)
7.2
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 07:19 EST by Ladislav Kolacek
Modified: 2017-01-09 11:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ladislav Kolacek 2015-11-09 07:19:47 EST
Description of problem:
Test case failue: https://tcms.engineering.redhat.com/case/195729/?from_plan=18766

Version-Release number of selected component (if applicable):
kernel-3.10.0-327.el7 (kernel-4.2.0-0.21.el7.aarch64)
PackageKit-1.0.7-5.el7

How reproducible:
100%

Steps to Reproduce:
  1. Open a terminal.
  2. download some rpm from the latest fedora rawhide (for example gnome-boxes)
  3. place it into /tmp/repo
  4. install createrepo tool
  5. in /tmp/repo execute 'createrepo .
  6. create  /etc/yum.repos.d/local.repo as follows

[local]
name=local
baseurl=file:///tmp/repo
enabled=1
gpgcheck=0

  7. As non-root user execute: 'pkcon install gnome-boxes' (or that newer package with missing deps)


Actual results:
Package not found: gnome-boxes
Command failed: This tool could not find any available package: No packages were found


Expected results:
There should be error shown saying what is missing. e.g on architecture x86_64 you obtain following message: 

Fatal error: gnome-boxes-3.19.1-1.fc24.x86_64 requires libvirt-gobject-1.0.so.0(LIBVIRT_GOBJECT_0.2.1)(64bit)
gnome-boxes-3.19.1-1.fc24.x86_64 requires libvirt-gobject-1.0.so.0(LIBVIRT_GOBJECT_0.2.2)(64bit)
gnome-boxes-3.19.1-1.fc24.x86_64 requires libvirt-gobject-1.0.so.0(LIBVIRT_GOBJECT_0.2.0)(64bit)

Additional info:
Problem appeared on following architectures: ppc64, ppc64le, s390x, aarch64.

Note You need to log in before you can comment on or make changes to this bug.