This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1279509 - dnf does not protect itself from being removed by itself
dnf does not protect itself from being removed by itself
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 10:36 EST by Stefan Paletta
Modified: 2015-11-16 05:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 05:53:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Paletta 2015-11-09 10:36:32 EST
Description of problem:

Despite /etc/dnf/protected.d/dnf.conf listing dnf, dnf will remove itself when asked, e.g. to remove python3.

$ cat /etc/dnf/protected.d/dnf.conf
dnf
$ 

Analysis with strace shows that this file is never accessed in the process.

Version-Release number of selected component (if applicable):
1.1.3-1.fc23

How reproducible:

sudo dnf -y remove python3

Actual results:

dnf removes python3 and packages that depend on it, including itself.

Expected results:

dnf aborts before removing any package.
Comment 1 Stefan Paletta 2015-11-16 05:53:00 EST
Closing as notabug because installing dnf-plugins-core fixes it.

Technically still a bug because system-upgrade from F22 left the system without that package.

Note You need to log in before you can comment on or make changes to this bug.