Bug 1279588 - Provider discovery fails with '[NoMethodError]: undefined method `<<' for nil:NilClass Method:[rescue in discoverHost]'
Provider discovery fails with '[NoMethodError]: undefined method `<<' for nil...
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
All Linux
high Severity high
: GA
: 5.6.0
Assigned To: Greg Blomquist
Dave Johnson
:
Depends On:
Blocks: 1289741
  Show dependency treegraph
 
Reported: 2015-11-09 14:52 EST by Thomas Hennessy
Modified: 2016-01-11 21:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289741 (view as bug list)
Environment:
Last Closed: 2016-01-11 21:34:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Hennessy 2015-11-09 14:52:18 EST
Description of problem: UI initiated Provider discovery under Infrastructure fails with reported error


Version-Release number of selected component (if applicable):
Version: 5.5.0.9-beta2 

How reproducible: from newly installed applaince attempt to discover known provider by providing a range of ipaddress including the known provider.


Steps to Reproduce:
1.Select 'discover infrastructure providers' from configurations dropdown box of Infrastructture\providers panel
2. Select all provider types (checkbox) and Select a range of ip addresses that contains a known provider
3. select the start button

Actual results:  no provider(s) are discovered


Expected results: two providers are in the range provided.  It was necessary to add these manually in order to continue testing.


Additional info:
error info from evm.log file
=====
[----] E, [2015-11-06T10:02:29.152947 #15532:ab1990] ERROR -- : [NoMethodError]: undefined method `<<' for nil:NilClass  Method:[rescue in discoverHost]
/opt/rh/cfme-gemset/gems/rest-client-2.0.0.rc1/lib/restclient/response.rb:56:in `fix_encoding'
/opt/rh/cfme-gemset/gems/rest-client-2.0.0.rc1/lib/restclient/response.rb:45:in `create'
/opt/rh/cfme-gemset/gems/rest-client-2.0.0.rc1/lib/restclient/request.rb:588:in `process_result'
/opt/rh/cfme-gemset/gems/rest-client-2.0.0.rc1/lib/restclient/request.rb:504:in `block in transmit'
/opt/rh/rh-ruby22/root/usr/share/ruby/net/http.rb:853:in `start'
/opt/rh/cfme-gemset/gems/rest-client-2.0.0.rc1/lib/restclient/request.rb:494:in `transmit'
/opt/rh/cfme-gemset/gems/rest-client-2.0.0.rc1/lib/restclient/request.rb:202:in `execute'
/opt/rh/cfme-gemset/gems/rest-client-2.0.0.rc1/lib/restclient/request.rb:52:in `execute'
/opt/rh/cfme-gemset/gems/rest-client-2.0.0.rc1/lib/restclient/resource.rb:51:in `get'
/opt/rh/cfme-gemset/gems/ovirt-0.7.0/lib/ovirt/service.rb:148:in `engine_ssh_public_key'
/opt/rh/cfme-gemset/gems/ovirt-0.7.0/lib/ovirt/service.rb:141:in `ovirt?'
/var/www/miq/vmdb/gems/pending/discovery/modules/RedHatRhevmProbe.rb:17:in `probe'
/var/www/miq/vmdb/gems/pending/discovery/DiscoverProbe.rb:9:in `block in getProductMod'
/var/www/miq/vmdb/gems/pending/discovery/DiscoverProbe.rb:5:in `foreach'
/var/www/miq/vmdb/gems/pending/discovery/DiscoverProbe.rb:5:in `getProductMod'
/var/www/miq/vmdb/gems/pending/discovery/MiqDiscovery.rb:83:in `scanHost'
/var/www/miq/vmdb/app/models/host.rb:1059:in `discoverHost'
/var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:151:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:323:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:320:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:320:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:142:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:123:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:24:in `start_worker'
/var/www/miq/vmdb/lib/workers/bin/worker.rb:2:in `<top (required)>'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/runner.rb:60:in `load'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/runner.rb:60:in `<top (required)>'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:123:in `require'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:90:in `runner'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
/opt/rh/cfme-gemset/bundler/gems/rails-a37d0e57571f/railties/lib/rails/commands.rb:17:in `<top (required)>'
/var/www/miq/vmdb/bin/rails:4:in `require'
/var/www/miq/vmdb/bin/rails:4:in `<main>'
[----] E, [2015-11-06T10:02:29.153294 #15532:ab1990] ERROR -- : /opt/rh/cfme-gemset/gems/rest-client-2.0.0.rc1/lib/restclient/response.rb:59:in `rescue in fix_encoding'
***
=====
Comment 2 Greg Blomquist 2016-01-11 21:34:29 EST
I couldn't reproduce the error noted in the logs on a 5.5.z appliance in QE.

When I initiated a discovery for RHEVM given an IP range with at least two RHEVM providers, I discovered both providers.

Note You need to log in before you can comment on or make changes to this bug.