Bug 127961 - /dev/hdg3 swap isn't recognized with SATA
/dev/hdg3 swap isn't recognized with SATA
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-15 14:04 EDT by Horst H. von Brand
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-15 14:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2004-07-15 14:04:00 EDT
Description of problem:
Trying to upgrade FC2 (SATA disk, swap is configured as /dev/hdg3 by
previous (FC2t3 or FC2) install, the upgrade goes south. Commenting
that entry in /etc/fstab fixes that.

Version-Release number of selected component (if applicable):


How reproducible:
Tried it once...

Steps to Reproduce:
1.Configure swap partition on /dev/hdg3 [Beats me why it is there...]
2.
3.
  
Actual results:
Upgrade crashes

Expected results:
Smoth upgrade

Additional info:
Comment 1 Jeremy Katz 2004-07-15 14:53:50 EDT
anaconda expects that your system is properly functioning before an
upgrade (ie, all partitions and swap partitions trying to be mounted
exist)
Comment 2 Horst H. von Brand 2004-07-16 14:10:34 EDT
System _was_ working right with FC2, and the FC3t1 upgrade failed.

Had to go back to FC2 (extreme breakage with LVM). And again, going
back  swap doesn't work: It is /dev/sdaX in FC3t1 and /dev/hdgX in FC2.
Comment 3 Japheth Cleaver 2004-08-18 15:18:04 EDT
This is related to the a kernel update that was distributed on FC2. 
At some point, the kernel was updated to treat SATA drives as /dev/sd 
instead of /dev/hd. This update package was distributed with NO 
apparent logic for updating fstab entries. Presumably, FC3t1 has the 
same most-current kernel version which is causing the problem.

The issue is that an updated kernel was released without ANY munging 
of the /etc/fstab file.

This is properly an FC2 bug.

Note You need to log in before you can comment on or make changes to this bug.