Bug 1279616 - The last breakpoint in the list is the one that is cleared when you proceed through openstack overcloud update stack with -i
The last breakpoint in the list is the one that is cleared when you proceed t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: RHOS Maint
Shai Revivo
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 16:03 EST by James Slagle
Modified: 2017-09-11 13:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-05 15:23:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 246577 None None None Never

  None (edit)
Description James Slagle 2015-11-09 16:03:10 EST
Description of problem:
openstack overcloud update stack should be run with -i (interactive) to pause on breakpoints. The issue is that it's quite confusing what breakpoint you're actually clearing when prompted.

Here's some sample output during the update:

[stack@instack ~]$ openstack overcloud update stack overcloud -i --templates templates-y1 -e templates-y1/overcl
oud-resource-registry-puppet.yaml -e templates-y1/environments/network-isolation.yaml -e templates-y1/environmen
ts/net-single-nic-with-vlans.yaml -e custom-environment-7.1.yaml -e /home/stack/update.yaml                     
starting package update on stack overcloud
IN_PROGRESS
<snip>
IN_PROGRESS
WAITING
not_started: [u'overcloud-compute-0', u'overcloud-controller-0', u'overcloud-controller-1', u'overcloud-controller-2']
on_breakpoint: [u'overcloud-cephstorage-0']
Breakpoint reached, continue? Regexp or Enter=proceed, no=cancel update, C-c=quit interactive mode: 
removing breakpoint on overcloud-cephstorage-0
IN_PROGRESS
<snip>
IN_PROGRESS
WAITING
completed: [u'overcloud-cephstorage-0']
on_breakpoint: [u'overcloud-compute-0', u'overcloud-controller-0', u'overcloud-controller-1', u'overcloud-controller-2']
Breakpoint reached, continue? Regexp or Enter=proceed, no=cancel update, C-c=quit interactive mode: 
removing breakpoint on overcloud-controller-2
IN_PROGRESS
<snip>
IN_PROGRESS
WAITING
completed: [u'overcloud-cephstorage-0', u'overcloud-controller-2']
on_breakpoint: [u'overcloud-controller-0', u'overcloud-controller-1', u'overcloud-compute-0']
Breakpoint reached, continue? Regexp or Enter=proceed, no=cancel update, C-c=quit interactive mode: 
removing breakpoint on overcloud-compute-0
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS


The first time you are prompted, there is only one breakpoint in the list: overcloud-cephstorage-0'
It's obvious what will be cleared when you press Enter.

Now consider the next 2 prompts:

completed: [u'overcloud-cephstorage-0']
on_breakpoint: [u'overcloud-compute-0', u'overcloud-controller-0', u'overcloud-controller-1', u'overcloud-controller-2']
Breakpoint reached, continue? Regexp or Enter=proceed, no=cancel update, C-c=quit interactive mode: 
removing breakpoint on overcloud-controller-2

and

completed: [u'overcloud-cephstorage-0', u'overcloud-controller-2']
on_breakpoint: [u'overcloud-controller-0', u'overcloud-controller-1', u'overcloud-compute-0']
Breakpoint reached, continue? Regexp or Enter=proceed, no=cancel update, C-c=quit interactive mode: 
removing breakpoint on overcloud-compute-0

Note that in both cases when I pressed Enter, the last breakpoint in the list was cleared. This may be as designed, but is very confusing. There's no way we could expect anyone to know that.

Also, what is "Regexp" prompting the user to do?
Comment 2 James Slagle 2015-11-17 14:54:06 EST
i threw a quick patch for this one upstream
Comment 3 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Jaromir Coufal 2016-10-05 15:23:02 EDT
Should be in since 7.x

Note You need to log in before you can comment on or make changes to this bug.