Bug 1279934 - SELinux is preventing abrt-hook-ccpp from 'read' accesses on the file hl2_linux.
SELinux is preventing abrt-hook-ccpp from 'read' accesses on the file hl2_linux.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1bac417073d016f0c1eba09bb30...
:
: 1281275 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 09:23 EST by Jia Yuan Lo
Modified: 2015-11-20 06:22 EST (History)
6 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-154.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 05:54:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jia Yuan Lo 2015-11-10 09:23:21 EST
Description of problem:
SELinux is preventing abrt-hook-ccpp from 'read' accesses on the file hl2_linux.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed read access on the hl2_linux file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                hl2_linux [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64 #1 SMP Tue
                              Oct 27 04:29:56 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-10 22:02:04 MYT
Last Seen                     2015-11-10 22:02:04 MYT
Local ID                      b24d2ade-26c3-421a-95f5-814c93080176

Raw Audit Messages
type=AVC msg=audit(1447164124.144:515): avc:  denied  { read } for  pid=4070 comm="abrt-hook-ccpp" name="hl2_linux" dev="sda5" ino=299716431 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file permissive=1


Hash: abrt-hook-ccpp,abrt_dump_oops_t,user_home_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-20 05:54:37 EST
Could you please update your SELinux policy packages? Thank you.
Comment 2 Miroslav Grepl 2015-11-20 06:22:56 EST
*** Bug 1281275 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.