Bug 1279947 - [RFE] Manager and Viewer shall include also other plugin added manager or viewer roles
[RFE] Manager and Viewer shall include also other plugin added manager or vie...
Status: CLOSED DUPLICATE of bug 1304608
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks: 1122832 260381
  Show dependency treegraph
 
Reported: 2015-11-10 09:53 EST by Peter Vreman
Modified: 2017-04-25 12:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-02 05:41:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vreman 2015-11-10 09:53:05 EST
Description of problem:
With the multiple plugins the Roles are getting a chaos

With Sat6.1.3 there are:
Discovery Reader
Discovery Manager
Tasks Manager
Tasks Reader
Red Hat Access Logs
Access Insights Viewer
Access Insights Admin
Boot disk access
View compliance reports
Edit compliance policies
ABRT reports handling
Manager
Edit partition tables
View hosts
Edit hosts
Viewer
Site manager

To assign a "Manager" role to a user you have to go through the list and add all ".... Manager" and .... Amdin" roles.

This is an error prone situation where you easily for one or more "... Manager" roles.

Out-of-the-box the roles shall be simple and including the plugins roles.
E.g. the Manager role shall include everything, also the other Manager roles
E.g. the Viewer role shall also include the other ".... Viewer" roles.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a userA with Manager role
2. Create a userB with Viewer role
3.

Actual results:
UserA can only manage Provisioning, not the plugins
userB can only view provisioning, not the plugins

Expected results:
UserA can manage everything, including the Abrt,Insight,Openscap,Discovery,etc..
UserB can view everything, including the Abrt,Insight,Openscap,Discovery,etc..


Additional info:
Comment 2 Bryan Kearney 2016-07-08 16:46:20 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 4 Marek Hulan 2016-12-02 05:41:38 EST

*** This bug has been marked as a duplicate of bug 1304608 ***
Comment 5 Marek Hulan 2016-12-02 05:53:36 EST
Thanks for the report Peter, I joined this to the BZ which covers the same. You can follow the progress in bz 1304608.

Note You need to log in before you can comment on or make changes to this bug.